aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-23 23:53:47 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-24 16:04:38 +0100
commitf5db04e8ea8377046a86885fdd5a83e948b54918 (patch)
treefde0f16a05730ff994c62c85be1cf29b383cd663 /target
parentc58959dc45a0396dcd4afe0a066f7d466f48a8a9 (diff)
downloadupstream-f5db04e8ea8377046a86885fdd5a83e948b54918.tar.gz
upstream-f5db04e8ea8377046a86885fdd5a83e948b54918.tar.bz2
upstream-f5db04e8ea8377046a86885fdd5a83e948b54918.zip
ramips: add support for Mercusys MR70X
Hardware ======== - SoC: MediaTek MT7621AT (880MHz, Duel-Core) - RAM: DDR3 128MB - Flash: Winbond W25Q128JV (SPI-NOR 16MB) - WiFi: MediaTek MT7915D (2.4GHz, 5GHz, DBDC) - Ethernet: MediaTek MT7530 (WAN x1, LAN x3, SoC) - UART: >TX RX GND 3v3 (115200 8N1, J1) Do not connect 3v3. TX is marked with an arrow. Installation ============ Flash factory image. This can be done using stock web ui. Revert to stock firmware ======================== Flash stock firmware via OEM Web UI Recovery mode. Web UI Recovery method ====================== 1. Unplug the router 2. Plug in and hold reset button 5~10 secs 3. Set your computer IP address manually to 192.168.1.x / 255.255.255.0 4. Flash image with web browser to 192.168.1.1 Co-authored-by: Robert Senderek <robert.senderek@10g.pl> Co-authored-by: Yoonji Park <koreapyj@dcmys.kr> Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 47de2c686291e69afc9f443e27e1dfd11ed5fbe7)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_mercusys_mr70x-v1.dts165
-rw-r--r--target/linux/ramips/image/mt7621.mk13
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac9
3 files changed, 183 insertions, 4 deletions
diff --git a/target/linux/ramips/dts/mt7621_mercusys_mr70x-v1.dts b/target/linux/ramips/dts/mt7621_mercusys_mr70x-v1.dts
new file mode 100644
index 0000000000..7eb94ba9cf
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_mercusys_mr70x-v1.dts
@@ -0,0 +1,165 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "mercusys,mr70x-v1", "mediatek,mt7621-soc";
+ model = "Mercusys MR70X v1";
+
+ aliases {
+ led-boot = &led_power_green;
+ led-failsafe = &led_power_orange;
+ led-running = &led_power_green;
+ led-upgrade = &led_power_orange;
+ label-mac-device = &gmac0;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power_green: power-green {
+ label = "green:power";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ led_power_orange: power-orange {
+ label = "orange:power";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <80000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x040000 0xf60000>;
+ };
+
+ config: partition@fa0000 {
+ label = "config";
+ reg = <0xfa0000 0x010000>;
+ read-only;
+ };
+
+ partition@fb0000 {
+ label = "tplink";
+ reg = <0xfb0000 0x040000>;
+ read-only;
+ };
+
+ radio: partition@ff0000 {
+ label = "radio";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x0>;
+ nvmem-cells = <&macaddr_config_8>;
+ nvmem-cell-names = "mac-address";
+ mediatek,disable-radar-background;
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_config_8>;
+ nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+ status = "okay";
+ label = "wan";
+ phy-handle = <&ethphy0>;
+
+ nvmem-cells = <&macaddr_config_8>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <1>;
+};
+
+&mdio {
+ ethphy0: ethernet-phy@0 {
+ reg = <0>;
+ };
+};
+
+&switch0 {
+ ports {
+ port@1 {
+ status = "okay";
+ label = "lan1";
+ };
+
+ port@2 {
+ status = "okay";
+ label = "lan2";
+ };
+
+ port@3 {
+ status = "okay";
+ label = "lan3";
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "i2c", "uart3";
+ function = "gpio";
+ };
+};
+
+&config {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_config_8: macaddr@8 {
+ reg = <0x8 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 11a1e4cb6a..df2b935c88 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1143,6 +1143,19 @@ define Device/mediatek_mt7621-eval-board
endef
TARGET_DEVICES += mediatek_mt7621-eval-board
+define Device/mercusys_mr70x-v1
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_VENDOR := Mercusys
+ DEVICE_MODEL := MR70X
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7915e -uboot-envtools
+ TPLINK_BOARD_ID := MR70X
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ IMAGE_SIZE := 15744k
+endef
+TARGET_DEVICES += mercusys_mr70x-v1
+
define Device/MikroTik
$(Device/dsa-migration)
DEVICE_VENDOR := MikroTik
diff --git a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index d4f259e141..07cfd9c51a 100644
--- a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -75,6 +75,11 @@ case "$board" in
[ "$PHYNBR" = "0" ] && macaddr_add $hw_mac_addr 2 > /sys${DEVPATH}/macaddress
[ "$PHYNBR" = "1" ] && macaddr_add $hw_mac_addr 3 > /sys${DEVPATH}/macaddress
;;
+ mercusys,mr70x-v1|\
+ tplink,archer-ax23-v1)
+ hw_mac_addr="$(mtd_get_mac_binary config 0x8)"
+ [ "$PHYNBR" = "1" ] && macaddr_add "$hw_mac_addr" -1 > "/sys${DEVPATH}/macaddress"
+ ;;
mts,wg430223)
hw_mac_addr=$(macaddr_add $(mtd_get_mac_encrypted_arcadyan "board_data") 1)
[ "$PHYNBR" = "0" ] && echo -n "$hw_mac_addr" > /sys${DEVPATH}/macaddress
@@ -98,10 +103,6 @@ case "$board" in
hw_mac_addr="$(mtd_get_mac_binary factory 0x4)"
[ "$PHYNBR" = "1" ] && macaddr_add $hw_mac_addr "0x100000" > /sys${DEVPATH}/macaddress
;;
- tplink,archer-ax23-v1)
- hw_mac_addr="$(mtd_get_mac_binary config 0x8)"
- [ "$PHYNBR" = "1" ] && macaddr_add "$hw_mac_addr" -1 > "/sys${DEVPATH}/macaddress"
- ;;
tplink,eap615-wall-v1)
hw_mac_addr="$(mtd_get_mac_binary product-info 0x8)"
macaddr_add "$hw_mac_addr" "$PHYNBR" > "/sys${DEVPATH}/macaddress"