aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-01-03 12:44:51 +0100
committerPetr Štetiar <ynezz@true.cz>2023-02-08 09:16:43 +0100
commit7370479224dde700537a73a81706bde6db820d8a (patch)
tree077360ccf6b55375e2678d6fd94c3f0063d842e5 /target
parent52564e65d592cc691f7e93eeaa839785b5363e22 (diff)
downloadupstream-7370479224dde700537a73a81706bde6db820d8a.tar.gz
upstream-7370479224dde700537a73a81706bde6db820d8a.tar.bz2
upstream-7370479224dde700537a73a81706bde6db820d8a.zip
at91: sam9x,sama5: fix racy SD card image generation
We've few low spec (make -j3) build workers attached to the 22.03 buildbot instance which from time to time exhibit following build failure during image generation (shortened for brewity): + dd bs=512 if=root.ext4 of=openwrt-22.03...sdcard.img.gz.img dd: failed to open 'root.ext4': No such file or directory Thats happening likely due to the fact, that on buildbots we've `TARGET_PER_DEVICE_ROOTFS=y` which produces differently named filesystem image in the SD card image target dependency chain: make_ext4fs -L rootfs ... root.ext4+pkg=68b329da and that hardcoded `root.ext4` image filename becomes available from other Make targets in the later stages. So lets fix this issue by using IMAGE_ROOTFS Make variable which should contain proper path to the root filesystem image. Fixing remaining subtargets ommited in commit 5c3679e39b61 ("at91: sama7: fix racy SD card image generation"). Fixes: 5c3679e39b61 ("at91: sama7: fix racy SD card image generation") Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 3b669bc3f32f7594f38187a284a65ca2c35a0121)
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91/image/sam9x.mk2
-rw-r--r--target/linux/at91/image/sama5.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/at91/image/sam9x.mk b/target/linux/at91/image/sam9x.mk
index b6c5e33ac4..3f57f4c8c8 100644
--- a/target/linux/at91/image/sam9x.mk
+++ b/target/linux/at91/image/sam9x.mk
@@ -35,7 +35,7 @@ define Build/at91-sdcard
./gen_at91_sdcard_img.sh \
$@.img \
$@.boot \
- $(KDIR)/root.ext4 \
+ $(IMAGE_ROOTFS) \
$(AT91_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 39db3e1cd0..7f4dd3316a 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -39,7 +39,7 @@ define Build/at91-sdcard
./gen_at91_sdcard_img.sh \
$@.img \
$@.boot \
- $(KDIR)/root.ext4 \
+ $(IMAGE_ROOTFS) \
$(AT91_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)