aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2022-12-03 15:25:12 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-22 00:14:30 +0100
commit47ac52a7c443ef065c9a35db34712e382d364986 (patch)
tree8162702556f13b246ad2ab2f87a95899029f0719 /target
parentda79da3ac18995885e3fe0e540ce300ad6d768be (diff)
downloadupstream-47ac52a7c443ef065c9a35db34712e382d364986.tar.gz
upstream-47ac52a7c443ef065c9a35db34712e382d364986.tar.bz2
upstream-47ac52a7c443ef065c9a35db34712e382d364986.zip
ath79: image: don't depend on other COMPILE targets
A device COMPILE target should not depend on another COMPILE. Otherwise race condition may happen. The loader is very small. Compiling it twice shouldn't have a huge impact. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> (cherry picked from commit 17c6fb1054e3dde8fa573195acaac42a5edf0942)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 712ab941e1..8328be7667 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -83,7 +83,7 @@ define Device/loader-okli-uimage
LOADER_TYPE := bin
COMPILE := loader-$(1).bin loader-$(1).uImage
COMPILE/loader-$(1).bin := loader-okli-compile
- COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | \
+ COMPILE/loader-$(1).uImage := loader-okli-compile | pad-to 64k | \
lzma | uImage lzma
endef