aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2021-11-30 10:25:52 +0100
committerBaptiste Jonglez <git@bitsofnetworks.org>2022-07-01 12:46:45 +0200
commit3e38bd13537a79afe79e81235da9469fe190551b (patch)
treeea97ea51291b0d63da01ac17bce2846eee63a081 /target
parent80602d472aae6c75ca7adf9688a32a4d68c55112 (diff)
downloadupstream-3e38bd13537a79afe79e81235da9469fe190551b.tar.gz
upstream-3e38bd13537a79afe79e81235da9469fe190551b.tar.bz2
upstream-3e38bd13537a79afe79e81235da9469fe190551b.zip
ipq-wifi: remove packaged BDF-s for MikroTik devices
Since we now provide the BDF-s for MikroTik IPQ40xx devices on the fly, there is noneed to include package and ship them like we do now. This also resolves the performance issues that happen as MikroTik changes the boards and ships them under the same revision but they actually ship with and require a different BDF. Signed-off-by: Robert Marko <robimarko@gmail.com> (cherry picked from commit ab141a6e2cb645ff64adb107af2e8973a720c1c7) Signed-off-by: Thibaut VARĂˆNE <hacks@slashdirt.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index 037a042848..b2e8428e94 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -24,8 +24,7 @@ define Device/mikrotik_cap-ac
$(call Device/mikrotik_nor)
DEVICE_MODEL := cAP ac
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-mikrotik_cap-ac -kmod-ath10k-ct \
- kmod-ath10k-ct-smallbuffers
+ DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += mikrotik_cap-ac
@@ -33,8 +32,7 @@ define Device/mikrotik_hap-ac2
$(call Device/mikrotik_nor)
DEVICE_MODEL := hAP ac2
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-mikrotik_hap-ac2 -kmod-ath10k-ct \
- kmod-ath10k-ct-smallbuffers
+ DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += mikrotik_hap-ac2
@@ -45,7 +43,7 @@ define Device/mikrotik_hap-ac3
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_UBIFS_OPTS = -m $$(PAGESIZE) -e 124KiB -c $$(PAGESIZE) -x none
- DEVICE_PACKAGES := kmod-ledtrig-gpio ipq-wifi-mikrotik_hap-ac3
+ DEVICE_PACKAGES := kmod-ledtrig-gpio
endef
TARGET_DEVICES += mikrotik_hap-ac3
@@ -61,6 +59,6 @@ define Device/mikrotik_sxtsq-5-ac
$(call Device/mikrotik_nor)
DEVICE_MODEL := SXTsq 5 ac (RBSXTsqG-5acD)
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-mikrotik_sxtsq-5-ac rssileds
+ DEVICE_PACKAGES := rssileds
endef
TARGET_DEVICES += mikrotik_sxtsq-5-ac