aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-03 16:57:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-03 16:57:23 +0000
commit20483faed099e623b2dcbcf6edde729fd4f46ff5 (patch)
tree2ceb66403ff6b77d7421453a135a642c961c4a5d /target
parent81cda3e2f1cc7ae3c55185209134ee0cca2d0b27 (diff)
downloadupstream-20483faed099e623b2dcbcf6edde729fd4f46ff5.tar.gz
upstream-20483faed099e623b2dcbcf6edde729fd4f46ff5.tar.bz2
upstream-20483faed099e623b2dcbcf6edde729fd4f46ff5.zip
ar71xx: create initramfs images for the newer TP-Link boards
SVN-Revision: 29410
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 73f816f4da..411fd16296 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -308,6 +308,14 @@ define Image/Build/TPLINK-LZMA
-o $(call sysupname,$(1),$(2))
endef
+define Image/Build/TPLINK-LZMA/initramfs
+ $(call PatchKernelLzma,$(2),$(3))
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
+ -B $(4) -N OpenWrt -V $(REVISION) -s \
+ -k $(KDIR)/vmlinux-$(2).bin.lzma \
+ -o $(call imgname,$(1),$(2))-uImage.bin
+endef
+
define Image/Build/CyberTAN
$(call MkuImageGzip,$(2),$(3))
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR)/vmlinux-$(2).uImage \