aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSzabolcs Hubai <szab.hu@gmail.com>2022-09-28 00:54:36 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-12 21:55:11 +0100
commitfafc9448aec907d40022fea0c3c75ad906b67d3e (patch)
treed88ac90e04d43393e87b80f55947b0f777295b4c /target
parent292d3f00c713c3368ca2a7b5bc480b76d3f74c50 (diff)
downloadupstream-fafc9448aec907d40022fea0c3c75ad906b67d3e.tar.gz
upstream-fafc9448aec907d40022fea0c3c75ad906b67d3e.tar.bz2
upstream-fafc9448aec907d40022fea0c3c75ad906b67d3e.zip
ramips: rt3883: use seama-lzma-loader for D-Link DIR-645
In the support topic [0] of the GitHub issue #10634 it was found out (based on boot logs) that the uimage-lzma-loader (commit 09faa73c53bd) never worked, as an earlier workaround (commit 6fba88de1913) negated the recipe: 3: System Boot system code via Flash. ## Booting image at bc050000 ... raspi_read: from:50000 len:40 .raspi_read: from:50000 len:c .raspi_read: from:50000 len:1fa000 ................................We have SEAMA, Image Size = 2072512 Verifying Checksum ... Uncompressing SEAMA linux.lzma ... OK ## Transferring control to Linux (at address 80000000) ... ## Giving linux memsize in MB, 64 Starting kernel ... [ 0.000000] Linux version 5.4.188 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16554-1d4dea6d4f)) #0 Sat Apr 16 12:59:34 2022 [ 0.000000] SoC Type: Ralink RT3883 ver:1 eco:5 [ 0.000000] printk: bootconsolde [early0] enabled [ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc) [ 0.000000] MIPS: machine is D-Link DIR-645 [ 0.000000] Initrd not found or empty - disabling initrd Using the new seama-lzma-loader it's able to boot OpenWrt 22.03 and OpenWrt SNAPSHOT too: 3: System Boot system code via Flash. ## Booting image at bc050000 ... raspi_read: from:50000 len:40 .raspi_read: from:50000 len:c .raspi_read: from:50000 len:48b004 .........................................................................We have SEAMA, Image Size = 4763588 Verifying Checksum ... Uncompressing SEAMA linux.lzma ... OK ## Transferring control to Linux (at address 80000000) ... ## Giving linux memsize in MB, 64 Starting kernel ... OpenWrt kernel loader for MIPS based SoC Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org> Decompressing kernel... done! Starting kernel at 80000000... [ 0.000000] Linux version 5.10.144 (xabolcs@ut2004) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 11.3.0 r20774+2-b71affaf8b) 11.3.0, GNU ld (GNU Binutils) 2.37) #0 Tue Sep 27 23:02:30 2022 [ 0.000000] SoC Type: Ralink RT3883 ver:1 eco:5 [ 0.000000] printk: bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc) [ 0.000000] MIPS: machine is D-Link DIR-645 [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes. [ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 16256 [ 0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2 The OKLI Loader is unable to read the flash on this SoC: Looking for OpenWrt image... not found! ('0xddbaddba' at 0xbc051000) 0: https://forum.openwrt.org/t/136435 Fixes: GitHub issue #10634 ("V22.03.0 release currently does not work on D-Link DIR-645") Fixes: 09faa73c53bd ("ramips: rt3883: use lzma-loader for DIR-645") Tested-by: Glenn Fowler <gfowler1@outlook.com> Signed-off-by: Szabolcs Hubai <szab.hu@gmail.com> (cherry picked from commit c293b492dfa114b67e90d5434edfeba17ba29980)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/rt3883.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index dd9b9ae716..ce0e934eb3 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -32,12 +32,10 @@ endef
TARGET_DEVICES += belkin_f9k1109v1
define Device/dlink_dir-645
- $(Device/seama)
- $(Device/uimage-lzma-loader)
+ $(Device/seama-lzma-loader)
SOC := rt3662
BLOCKSIZE := 4k
IMAGE_SIZE := 7872k
- KERNEL := kernel-bin | append-dtb | lzma -d10
SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-645