aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSzabolcs Hubai <szab.hu@gmail.com>2022-09-28 02:55:01 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-12 21:55:11 +0100
commitca124d2e4b5cb2ea74640198721e85571a5c43b3 (patch)
treeaf5f1af6f6a577d0c3e9257cb4b61a8866b17c1f /target
parentfafc9448aec907d40022fea0c3c75ad906b67d3e (diff)
downloadupstream-ca124d2e4b5cb2ea74640198721e85571a5c43b3.tar.gz
upstream-ca124d2e4b5cb2ea74640198721e85571a5c43b3.tar.bz2
upstream-ca124d2e4b5cb2ea74640198721e85571a5c43b3.zip
ramips: mt7621: use seama-lzma-loader for D-Link DIR-860L B1
Fix the LZMA ERROR 1 with a single line of recipe instead of duplicating "uimage-lzma-loader". While reviewing my original submission of commit ce1957100411 David suggested to use $(Device/uimage-lzma-loader), but due to the specific needs of the vendor bootloader that simple oneliner didn't work. The new $(Device/seama-lzma-loader) is for those SEAMA capable bootloaders. Signed-off-by: Szabolcs Hubai <szab.hu@gmail.com> (cherry picked from commit 18801f26485e3a0dcb79dc9f9b174aed5821b758)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7621.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 94b040e361..adf8382002 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -427,11 +427,8 @@ TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
$(Device/dsa-migration)
- $(Device/seama)
+ $(Device/seama-lzma-loader)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
- LOADER_TYPE := bin
- KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | relocate-kernel | \
- lzma -a0 | uImage lzma
IMAGE_SIZE := 16064k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-860L