aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-28 18:14:54 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-30 00:37:35 +0200
commitd37125b3f3909c26c1e4648411a5fa5d956df6d0 (patch)
tree609dfe742b3b5138c30d81a9d8c6495f7f83d8f9 /target
parentbce00f47e5d67e5a33e9d7fa137cbe0a5d3d334b (diff)
downloadupstream-d37125b3f3909c26c1e4648411a5fa5d956df6d0.tar.gz
upstream-d37125b3f3909c26c1e4648411a5fa5d956df6d0.tar.bz2
upstream-d37125b3f3909c26c1e4648411a5fa5d956df6d0.zip
ath79: remove redundant BLOCKSIZE of 64k from devices
BLOCKSIZE = 64k is set in Device/Default, i.e. global default on the target. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/generic.mk2
-rw-r--r--target/linux/ath79/image/nand.mk2
2 files changed, 0 insertions, 4 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fc1b8fe0d2..d8db054312 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1705,7 +1705,6 @@ define Device/openmesh_common_64k
DEVICE_VENDOR := OpenMesh
DEVICE_PACKAGES := uboot-envtools
IMAGE_SIZE := 7808k
- BLOCKSIZE := 64k
OPENMESH_CE_TYPE :=
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
pad-to $$(BLOCKSIZE)
@@ -1978,7 +1977,6 @@ define Device/plasmacloud_pa300-common
DEVICE_VENDOR := Plasma Cloud
DEVICE_PACKAGES := uboot-envtools
IMAGE_SIZE := 7168k
- BLOCKSIZE := 64k
IMAGES += factory.bin
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-to $$(BLOCKSIZE)
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA300
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 20cb2f60fa..52631789d9 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -102,7 +102,6 @@ TARGET_DEVICES += glinet_gl-ar300m-nand
define Device/glinet_gl-ar300m-nor
$(Device/glinet_gl-ar300m-common-nand)
DEVICE_VARIANT := NOR
- BLOCKSIZE := 64k
SUPPORTED_DEVICES += glinet,gl-ar300m-nand gl-ar300m
endef
TARGET_DEVICES += glinet_gl-ar300m-nor
@@ -128,7 +127,6 @@ TARGET_DEVICES += glinet_gl-ar750s-nor-nand
define Device/glinet_gl-ar750s-nor
$(Device/glinet_gl-ar750s-common)
DEVICE_VARIANT := NOR
- BLOCKSIZE := 64k
SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s glinet,gl-ar750s-nor-nand
endef
TARGET_DEVICES += glinet_gl-ar750s-nor