aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBjørn Mork <bjorn@mork.no>2021-06-24 23:04:08 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-10-30 15:00:22 +0200
commitdaefc646e6d4f1f730c5957b5954b88abe7c00f3 (patch)
tree731ddb84bc6132319fd74d9d7f8cd84a54004f08 /target
parent6102f883ce7f32988d22b7fc5b79356e3d06c1dc (diff)
downloadupstream-daefc646e6d4f1f730c5957b5954b88abe7c00f3.tar.gz
upstream-daefc646e6d4f1f730c5957b5954b88abe7c00f3.tar.bz2
upstream-daefc646e6d4f1f730c5957b5954b88abe7c00f3.zip
realtek: fix ZyXEL initramfs image generation
The current rule produces empty trailers, causing the OEM firmware update application to reject our images. The double expansion of a makefile variable does not work inside shell code. The second round is interpreted as a shell expansion, attempting to run the command ZYXEL_VERS instead of expanding the $(ZYXEL_VERS) makefile variable. Fix by removing one level of variable indirection. Fixes: c6c8d597e183 ("realtek: Add generic zyxel_gs1900 image definition") Tested-by: Sander Vanheule <sander@svanheule.net> Signed-off-by: Bjørn Mork <bjorn@mork.no>
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 5e4b4cde80..a7961970a3 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -10,7 +10,7 @@ DEVICE_VARS += ZYXEL_VERS
define Build/zyxel-vers
( echo VERS;\
- for hw in $(1); do\
+ for hw in $(ZYXEL_VERS); do\
echo -n "V9.99($$hw.0) | ";\
date -d @$(SOURCE_DATE_EPOCH) +%m/%d/%Y;\
done ) >> $@
@@ -117,7 +117,7 @@ define Device/zyxel_gs1900
IMAGE_SIZE := 6976k
DEVICE_VENDOR := ZyXEL
UIMAGE_MAGIC := 0x83800000
- KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | zyxel-vers $$$$(ZYXEL_VERS) | \
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | zyxel-vers | \
uImage gzip
endef