aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2021-12-26 11:59:44 +0100
committerDavid Bauer <mail@david-bauer.net>2021-12-27 03:07:22 +0100
commitcfa670bf16afc10855ca0adec50a807b684ba6a7 (patch)
tree21630b9649eeaf99ebf5249cef7fe85778bc5bc3 /target
parent0dc4ab344bf52fce60128f0d710b88150ed47507 (diff)
downloadupstream-cfa670bf16afc10855ca0adec50a807b684ba6a7.tar.gz
upstream-cfa670bf16afc10855ca0adec50a807b684ba6a7.tar.bz2
upstream-cfa670bf16afc10855ca0adec50a807b684ba6a7.zip
ath79: add missing UBNT_REVISION
The UBNT_REVISION was already added for the ubnt-xw target because: U-boot bootloader on M-XW devices expects factory image revision version in specific format. On airOS v6.1.7 with `U-Boot 1.1.4-s1039 (May 24 2017 - 15:58:18)` bootloader checks if the revision major(?) number is actually a number, but in currently generated images there's OpenWrt text and so the check fails ... By placing arbitrary correct number first in major version, we make the bootloader happy and we can flash factory images over TFTP again. commit d42a7c469909 ("ath79: ubnt-m-xw: Fix factory image flashing using TFTP recovery method") Fixes errors in the form of (tftp flashing): sent DATA <block=8577, 412 bytes> received ERROR <code=2, msg=Firmware check failed> Error code 2: Firmware check failed The missing UBNT_REVISION was not noticed before, since the UBNT_REVISION field for the ubnt-xm target was also set to: "42.OpenWrt-..." Probably, UBNT_REVISION for the ubnt-xm target was set by the ubnt-xw and was never overridden somewhere else. However, it is missing and should be part of the ubnt-xm device. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 3888e1652b..bb5eaa5458 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -103,6 +103,7 @@ define Device/ubnt-xm
IMAGE_SIZE := 7448k
UBNT_BOARD := XM
UBNT_CHIP := ar7240
+ UBNT_REVISION := 42.$(UBNT_REVISION)
UBNT_TYPE := XM
UBNT_VERSION := 6.0.0
KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma