aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-06-15 12:36:37 +0200
committerRafał Miłecki <rafal@milecki.pl>2022-07-08 11:28:01 +0200
commitbd826dc9f9b2fdb4ae17593beb42e163616073e3 (patch)
tree18d4515b964a24b7b9306795d3306ebdd7301b0c /target
parentda7c57b086d893aab2ce446b99d2d22b538d67d8 (diff)
downloadupstream-bd826dc9f9b2fdb4ae17593beb42e163616073e3.tar.gz
upstream-bd826dc9f9b2fdb4ae17593beb42e163616073e3.tar.bz2
upstream-bd826dc9f9b2fdb4ae17593beb42e163616073e3.zip
kernel: drop patch adding hardcoded kernel compilation flags
1. KCFLAGS should be used for custom flags 2. Optimization flags are arch / SoC specific 3. -fno-reorder-blocks may *worsen* network performace on some SoCs 4. Usage of flags was *reversed* since 5.4 and noone reported that If we really need custom flags then CONFIG_KERNEL_CFLAGS should get default value adjusted properly (per target). Ref: 4e0c54bc5bc8 ("kernel: add support for kernel 5.4") Link: http://lists.openwrt.org/pipermail/openwrt-devel/2022-June/038853.html Link: https://patchwork.ozlabs.org/project/openwrt/patch/20190409093046.13401-1-zajec5@gmail.com/ Cc: Felix Fietkau <nbd@nbd.name> Cc: Hauke Mehrtens <hauke@hauke-m.de> Cc: Rui Salvaterra <rsalvaterra@gmail.com> Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Acked-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 22168ae68101b95d03741b0e9e8ad20b8a5ae5b7)
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/pending-5.10/201-extra_optimization.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/target/linux/generic/pending-5.10/201-extra_optimization.patch b/target/linux/generic/pending-5.10/201-extra_optimization.patch
deleted file mode 100644
index dcf39c574f..0000000000
--- a/target/linux/generic/pending-5.10/201-extra_optimization.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Felix Fietkau <nbd@nbd.name>
-Subject: Upgrade to Linux 2.6.19
-
-- Includes large parts of the patch from #1021 by dpalffy
-- Includes RB532 NAND driver changes by n0-1
-
-[john@phrozen.org: feix will add this to his upstream queue]
-
-lede-commit: bff468813f78f81e36ebb2a3f4354de7365e640f
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
- Makefile | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- a/Makefile
-+++ b/Makefile
-@@ -739,7 +739,7 @@ KBUILD_CFLAGS += -O2
- else ifdef CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE_O3
- KBUILD_CFLAGS += -O3
- else ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-reorder-blocks -fno-tree-ch
- endif
-
- # Tell gcc to never replace conditional load with a non-conditional one