aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMarkus Stockhausen <markus.stockhausen@gmx.de>2022-07-06 13:43:23 +0200
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2022-07-08 22:10:16 -0300
commit945b13e369ad262ad6d7086e34e048ff6f797bfc (patch)
tree7877b558686535ed8ebc42364c1c908df5f944e9 /target
parent3fbf45bd0948a335d25edc571b3b1c86a2aa19e6 (diff)
downloadupstream-945b13e369ad262ad6d7086e34e048ff6f797bfc.tar.gz
upstream-945b13e369ad262ad6d7086e34e048ff6f797bfc.tar.bz2
upstream-945b13e369ad262ad6d7086e34e048ff6f797bfc.zip
realtek: build sane factory images for DGS-1210 models
During upload of firmware images the WebUI and CLI patch process extracts a version information from the uploaded file and stores it onto the jffs2 partition. To be precise it is written into the flash.txt or flash2.txt files depending on the selected target image. This data is not used anywhere else. The current OpenWrt factory image misses this label. Therefore version information shows only garbage. Fix this. Before: DGS-1210-20> show firmware information IMAGE ONE: Version : xfo/QE~WQD"A\Scxq... Size : 5505185 Bytes After: DGS-1210-20> show firmware information IMAGE ONE: Version : OpenWrt Size : 5505200 Bytes Tested-by: Luiz Angelo Daros de Luca <luizluca@gmail.com> Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de> (cherry picked from commit fae3ac3560459320a88be86b31c572c4bca42645)
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/image/Makefile5
-rw-r--r--target/linux/realtek/image/rtl838x.mk3
2 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 3a1ba2f60e..cf779002e8 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -21,6 +21,11 @@ define Build/dlink-cameo
$(SCRIPT_DIR)/cameo-tag.py $@ $(DLINK_KERNEL_PART_SIZE)
endef
+define Build/dlink-version
+ echo -n "OpenWrt" >> $@
+ dd if=/dev/zero bs=25 count=1 >> $@
+endef
+
define Build/dlink-headers
dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index d72dc2191b..b0f307296d 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -23,7 +23,8 @@ define Device/d-link_dgs-1210
CAMEO_BOARD_VERSION := 32
IMAGES += factory_image1.bin
IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
- append-rootfs | pad-rootfs | pad-to 16 | check-size | dlink-headers
+ append-rootfs | pad-rootfs | pad-to 16 | check-size | \
+ dlink-version | dlink-headers
endef
define Device/d-link_dgs-1210-10p