aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMarkus Stockhausen <markus.stockhausen@gmx.de>2022-07-05 08:46:59 +0200
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2022-07-08 22:09:26 -0300
commit87e58a43eac981f5adcda0cd88fa8acb72266c61 (patch)
treec5ed708b1dd60538fd798d160d33246304e847bd /target
parentb151362d199e803c42e8c9e5411aab169fd770f2 (diff)
downloadupstream-87e58a43eac981f5adcda0cd88fa8acb72266c61.tar.gz
upstream-87e58a43eac981f5adcda0cd88fa8acb72266c61.tar.bz2
upstream-87e58a43eac981f5adcda0cd88fa8acb72266c61.zip
realtek: build DGS-1210 images with CAMEO tag
From now on we will insert CAMEO tags into sysupgrade images for DGS-1210 devices. This will make the "OS:...FAILED" and "FS:...FAILED" messages go away. Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de> (cherry picked from commit e763c4c89fc5569d7264ff60837eb4aff69a0bfb)
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/image/Makefile4
-rw-r--r--target/linux/realtek/image/rtl838x.mk1
2 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index b54a1f0a8d..3a1ba2f60e 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -17,6 +17,10 @@ define Build/zyxel-vers
done ) >> $@
endef
+define Build/dlink-cameo
+ $(SCRIPT_DIR)/cameo-tag.py $@ $(DLINK_KERNEL_PART_SIZE)
+endef
+
define Build/dlink-headers
dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index e71106d571..fee029aa3f 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -16,6 +16,7 @@ define Device/d-link_dgs-1210
IMAGE_SIZE := 13824k
DEVICE_VENDOR := D-Link
DLINK_KERNEL_PART_SIZE := 1572864
+ KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
endef
define Device/d-link_dgs-1210-10p