aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2021-11-03 10:27:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-12-13 23:22:29 +0100
commit82ce460ab106c1d3626607c4d867853cf385ad33 (patch)
tree4b8390f750fec9865e2bd35f24e9d1794b64d4d6 /target
parent68b4e9fe0eb80d85c24159a88b4dbc77b20116e2 (diff)
downloadupstream-82ce460ab106c1d3626607c4d867853cf385ad33.tar.gz
upstream-82ce460ab106c1d3626607c4d867853cf385ad33.tar.bz2
upstream-82ce460ab106c1d3626607c4d867853cf385ad33.zip
layerscape: armv8_64b: fix KERNEL_LOADADDR for linux >= 5.8
In kernel versions newer than 5.8 the arm64 TEXT_OFFSET (0x80000) has been set to 0x0 (and later removed). This will break Uimages with kernel load addresses that aren't 2MiB aligned any longer. Resulting in the kernel silently fail to boot. For layerscape armv8_64b targets this needs to be changed to 0x80000000 (start of RAM). Signed-off-by: Martin Schiller <ms@dev.tdt.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index 7148a2372a..7ff49c6555 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -8,7 +8,11 @@ define Device/Default
FILESYSTEMS := squashfs
KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_INITRAMFS = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+ifdef CONFIG_LINUX_5_4
KERNEL_LOADADDR := 0x80080000
+else
+ KERNEL_LOADADDR := 0x80000000
+endif
DEVICE_DTS = freescale/$(subst _,-,$(1))
IMAGE_SIZE := 64m
IMAGE/sysupgrade.bin = \