aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTorsten Duwe <duwe@lst.de>2021-09-22 10:52:51 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-12-29 20:35:57 +0100
commit7ea9936f7f32fd90af1a29775ac3b297d7775db7 (patch)
tree25ee3e6c279b4621d847af8b1dc32db4500b43c0 /target
parentafd7ec3b57c3ff66f0a8ed250ed468e23cc9cb27 (diff)
downloadupstream-7ea9936f7f32fd90af1a29775ac3b297d7775db7.tar.gz
upstream-7ea9936f7f32fd90af1a29775ac3b297d7775db7.tar.bz2
upstream-7ea9936f7f32fd90af1a29775ac3b297d7775db7.zip
bcm27xx: add AMP2 to HifiBerry DAC+ / DAC+ Pro package
According to the vendor [1] these HATs share the same DT overlay: hifiberry-dacplus. The PCM512x-compatible control unit is attached to I2C, so the additional snd-soc-pcm512x-i2c kernel module is required. Also explicitly note the Amp2 support to reduce confusion for those users. [1] <https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/> Signed-off-by: Torsten Duwe <duwe@lst.de> (added bcm27xx tag, changed commit message) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/bcm27xx/modules/sound.mk15
1 files changed, 9 insertions, 6 deletions
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index a6b1d73987..0823786d5c 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -527,24 +527,27 @@ $(eval $(call KernelPackage,sound-soc-hifiberry-dac))
define KernelPackage/sound-soc-hifiberry-dacplus
- TITLE:=Support for HifiBerry DAC+ / DAC+ Pro
+ TITLE:=Support for HifiBerry DAC+ / DAC+ Pro / Amp2
KCONFIG:= \
CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS \
- CONFIG_SND_SOC_PCM512x
+ CONFIG_SND_SOC_PCM512x \
+ CONFIG_SND_SOC_PCM512x_I2C
FILES:= \
$(LINUX_DIR)/drivers/clk/clk-hifiberry-dacpro.ko \
$(LINUX_DIR)/sound/soc/bcm/snd-soc-hifiberry-dacplus.ko \
- $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x-i2c.ko
AUTOLOAD:=$(call AutoLoad,68,clk-hifiberry-dacpro snd-soc-pcm512x \
- snd-soc-hifiberry-dacplus)
+ snd-soc-pcm512x-i2c snd-soc-hifiberry-dacplus)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2835
+ +kmod-i2c-bcm2835 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
define KernelPackage/sound-soc-hifiberry-dacplus/description
- This package contains support for HifiBerry DAC+ / DAC+ Pro
+ This package contains support for HifiBerry DAC+ / DAC+ Pro / Amp2
endef
$(eval $(call KernelPackage,sound-soc-hifiberry-dacplus))