aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAndré Valentin <avalentin@marcant.net>2021-09-17 21:48:55 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-10-31 21:24:47 +0100
commit766d1d675baf332251d0d80a11e835eeb05ada11 (patch)
tree4dc6590122ba462f3995a0753d3b48db4588a0a0 /target
parenteb00fb8f7153535512b2dad365e76a2bc0dfb6c1 (diff)
downloadupstream-766d1d675baf332251d0d80a11e835eeb05ada11.tar.gz
upstream-766d1d675baf332251d0d80a11e835eeb05ada11.tar.bz2
upstream-766d1d675baf332251d0d80a11e835eeb05ada11.zip
ath79: fix parallel image generation for Zyxel NBG6716
This changes the image generation to use a unique directory. With parallel building it may occur that two concurrent jobs try to create an image which leds to errors. It also removes a needless subdirecory. Signed-off-by: André Valentin <avalentin@marcant.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/nand.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 52631789d9..8d3d2ce5b2 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,13 +1,12 @@
# attention: only zlib compression is allowed for the boot fs
define Build/zyxel-buildkerneljffs
- rm -rf $(KDIR_TMP)/zyxelnbg6716
- mkdir -p $(KDIR_TMP)/zyxelnbg6716/image/boot
- cp $@ $(KDIR_TMP)/zyxelnbg6716/image/boot/vmlinux.lzma.uImage
+ mkdir -p $@.tmp/boot
+ cp $@ $@.tmp/boot/vmlinux.lzma.uImage
$(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
--big-endian --squash-uids -v -e 128KiB -q -f -n -x lzma -x rtime \
-o $@ \
- -d $(KDIR_TMP)/zyxelnbg6716/image
- rm -rf $(KDIR_TMP)/zyxelnbg6716
+ -d $@.tmp
+ rm -rf $@.tmp
endef
define Build/zyxel-factory