aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-07-04 14:23:06 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-07-15 15:22:08 +0200
commit409534860fd55be8c90ffc4b377ecbb3adb94784 (patch)
tree8653dde9289ee59c246a0dc50fb2545216811581 /target
parent1be4cad6690b1c509b6706a5ba4cafbb7ded4fb9 (diff)
downloadupstream-409534860fd55be8c90ffc4b377ecbb3adb94784.tar.gz
upstream-409534860fd55be8c90ffc4b377ecbb3adb94784.tar.bz2
upstream-409534860fd55be8c90ffc4b377ecbb3adb94784.zip
ath79: bsap18x0: pad rootfs image
This image is supposed to be written with help of bootloader to the flash, but as it stands, it's not aligned to block size and RedBoot will happily create non-aligned partition size in FIS directory. This could lead to kernel to mark the partition as read-only, therefore pad the image to block erase size boundary. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com> (cherry picked from commit 9decd2a8436d2bb6b5f436268c92a6e6728486ce)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 2b81690654..2d4d1e5c91 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -208,7 +208,7 @@ define Device/adtran_bsap1880
IMAGE_SIZE := 11200k
IMAGES += kernel.bin rootfs.bin
IMAGE/kernel.bin := append-kernel
- IMAGE/rootfs.bin := append-rootfs | pad-rootfs
+ IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to $$(BLOCKSIZE)
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
check-size | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef