aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2022-02-05 19:09:11 +0900
committerSungbo Eo <mans0n@gorani.run>2022-02-11 22:30:04 +0900
commit337e942290fa6a18e0289ae32420c5c402aead1a (patch)
tree6bd1fbe6812173988bbad5ee4bb0c22e3232f371 /target
parent34a373c0df0233150b5c87e9c925ca2b2b754a6e (diff)
downloadupstream-337e942290fa6a18e0289ae32420c5c402aead1a.tar.gz
upstream-337e942290fa6a18e0289ae32420c5c402aead1a.tar.bz2
upstream-337e942290fa6a18e0289ae32420c5c402aead1a.zip
ramips: add support for ELECOM WRC-2533GS2
ELECOM WRC-2533GS2 is a 2.4/5 GHz band 11ac (Wi-Fi 5) router, based on MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB (NT5CC64M16GP-DI) - Flash : SPI-NOR 16 MiB (MX25L12835FM2I-10G) - WLAN : 2.4/5GHz 4T4R (2x MediaTek MT7615) - Ethernet : 10/100/1000 Mbps x5 - Switch : MediaTek MT7530 (SoC) - LEDs/Keys : 4x/6x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J4: 3.3V, GND, TX, RX from ethernet port side - 57600n8 - Power : 12 VDC, 1.5 A Flash instruction using factory image: 1. Boot WRC-2533GS2 normally with "Router" mode 2. Access to "http://192.168.2.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory image and click apply ("適用") button 4. Wait ~120 seconds to complete flashing MAC Addresses: LAN : 04:AB:18:xx:xx:FB (Factory, 0xFFF4 (hex)) WAN : 04:AB:18:xx:xx:FC (Factory, 0xFFFA (hex)) 2.4 GHz : 04:AB:18:xx:xx:FD (Factory, 0x4 (hex)) 5 GHz : 04:AB:18:xx:xx:FE (Factory, 0x8004 (hex)) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-2533gs2.dts64
-rw-r--r--target/linux/ramips/image/mt7621.mk8
2 files changed, 72 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-2533gs2.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-2533gs2.dts
new file mode 100644
index 0000000000..0036b52032
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-2533gs2.dts
@@ -0,0 +1,64 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_elecom_wrc-gs-2pci.dtsi"
+
+/ {
+ compatible = "elecom,wrc-2533gs2", "mediatek,mt7621-soc";
+ model = "ELECOM WRC-2533GS2";
+};
+
+&partitions {
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xb00000>;
+ };
+
+ partition@b50000 {
+ label = "tm_pattern";
+ reg = <0xb50000 0x380000>;
+ read-only;
+ };
+
+ partition@ed0000 {
+ label = "tm_key";
+ reg = <0xed0000 0x80000>;
+ read-only;
+ };
+
+ partition@f50000 {
+ label = "nvram";
+ reg = <0xf50000 0x30000>;
+ read-only;
+ };
+
+ partition@f80000 {
+ label = "user_data";
+ reg = <0xf80000 0x80000>;
+ read-only;
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_fff4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&wan {
+ nvmem-cells = <&macaddr_factory_fffa>;
+ nvmem-cell-names = "mac-address";
+};
+
+&factory {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_fff4: macaddr@fff4 {
+ reg = <0xfff4 0x6>;
+ };
+
+ macaddr_factory_fffa: macaddr@fffa {
+ reg = <0xfffa 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 105f1f5b18..8e13920672 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -549,6 +549,14 @@ define Device/elecom_wrc-2533ghbk-i
endef
TARGET_DEVICES += elecom_wrc-2533ghbk-i
+define Device/elecom_wrc-2533gs2
+ $(Device/elecom_wrc-gs)
+ IMAGE_SIZE := 11264k
+ DEVICE_MODEL := WRC-2533GS2
+ ELECOM_HWNAME := WRC-2533GS2
+endef
+TARGET_DEVICES += elecom_wrc-2533gs2
+
define Device/elecom_wrc-2533gst
$(Device/elecom_wrc-gs)
IMAGE_SIZE := 11264k