aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 12:07:01 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 22:37:23 +0200
commit1553f58a988a6bdac5549cb8652d002c945c5181 (patch)
tree4684c8c25c9833300a9f582a71a6ae40a93be27a /target
parent8fdf77878f46cac683115c10ee91956a35e61046 (diff)
downloadupstream-1553f58a988a6bdac5549cb8652d002c945c5181.tar.gz
upstream-1553f58a988a6bdac5549cb8652d002c945c5181.tar.bz2
upstream-1553f58a988a6bdac5549cb8652d002c945c5181.zip
ramips: create common definition for I-O DATA NAND devices
Three of the I-O DATA devices with NAND flash share a lot of variables. Create a common definition for them to reduce duplicate code. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7621.mk34
1 files changed, 11 insertions, 23 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 101e5bbba6..88db43cb65 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -370,56 +370,44 @@ define Device/iodata_wn-ax1167gr
endef
TARGET_DEVICES += iodata_wn-ax1167gr
-define Device/iodata_wn-ax1167gr2
+define Device/iodata_nand
+ DEVICE_VENDOR := I-O DATA
BLOCKSIZE := 128k
PAGESIZE := 2048
UBINIZE_OPTS := -E 5
- UIMAGE_MAGIC := 0x434f4d42
KERNEL_SIZE := 4096k
IMAGE_SIZE := 51200k
- DEVICE_VENDOR := I-O DATA
- DEVICE_MODEL := WN-AX1167GR2
LOADER_TYPE := bin
KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+
+define Device/iodata_wn-ax1167gr2
+ $(Device/iodata_nand)
+ UIMAGE_MAGIC := 0x434f4d42
+ DEVICE_MODEL := WN-AX1167GR2
KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XBC.1)b10 | \
iodata-mstc-header
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_PACKAGES := kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += iodata_wn-ax1167gr2
define Device/iodata_wn-ax2033gr
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- UBINIZE_OPTS := -E 5
+ $(Device/iodata_nand)
UIMAGE_MAGIC := 0x434f4d42
- KERNEL_SIZE := 4096k
- IMAGE_SIZE := 51200k
- DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-AX2033GR
- LOADER_TYPE := bin
- KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(VST.1)C10 | \
iodata-mstc-header
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += iodata_wn-ax2033gr
define Device/iodata_wn-dx1167r
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- UBINIZE_OPTS := -E 5
+ $(Device/iodata_nand)
UIMAGE_MAGIC := 0x434f4d43
- KERNEL_SIZE := 4096k
- IMAGE_SIZE := 51200k
- DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-DX1167R
- LOADER_TYPE := bin
- KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XIK.1)b10 | \
iodata-mstc-header
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_PACKAGES := kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += iodata_wn-dx1167r