aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-04-07 00:36:25 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-07 21:08:10 +0200
commitd0965dc174b52da767e8eb8962c33d5b7af866d1 (patch)
treeeaf9593206b21006da9d02528725b4d4188cdf94 /target
parentf66521e71f3769b4fd7872ddb991efc37b9f6bd4 (diff)
downloadupstream-d0965dc174b52da767e8eb8962c33d5b7af866d1.tar.gz
upstream-d0965dc174b52da767e8eb8962c33d5b7af866d1.tar.bz2
upstream-d0965dc174b52da767e8eb8962c33d5b7af866d1.zip
at91: Automatically detect USB feature
The sama7 sub target does not have USB support, the feature should not be activated there. OpenWrt can automatically detect if the target supports USB by using the scripts/target-metadata.pl script. With the automatic detection USB support will only get activated on subtargest which actually support USB like sam9x and sama5. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit f6d566301ee3dc12fd41e131f89dfc4777b002f3)
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 36804a1eeb..af0dc3f338 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=at91
BOARDNAME:=Microchip (Atmel AT91)
-FEATURES:=ext4 squashfs targz usb usbgadget ubifs
+FEATURES:=ext4 squashfs targz usbgadget ubifs
SUBTARGETS:=sama7 sama5 sam9x
KERNEL_PATCHVER:=5.10