aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2022-06-22 23:38:26 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-25 00:05:21 +0200
commitb9d67e2608134e6d5c4f8c4d64be7271ccc8455c (patch)
treec840093434abfff7ab8b8ef33a8a501f0157067f /target
parent4130e7ed54ed59e0af00fbe07c492716335b3c99 (diff)
downloadupstream-b9d67e2608134e6d5c4f8c4d64be7271ccc8455c.tar.gz
upstream-b9d67e2608134e6d5c4f8c4d64be7271ccc8455c.tar.bz2
upstream-b9d67e2608134e6d5c4f8c4d64be7271ccc8455c.zip
ath79: fix rootfs padding for D-Link DAP-2xxx
It was observed that `rootfs_data` was sometimes not correctly erased after performing sysupgrade, resulting in previous settings to prevail. Add call to `wrgg-pad-rootfs` in sysupgrade image recipe to ensure any previous jffs2 will be wiped, consistent with DAP-2610 from the ipq40xx target, which introduced the double-flashing procedure for these devices. Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net> (cherry picked from commit f770c33d7bb94b610d3a1c1fa84bc917678b65bc)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/generic.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 5f8fc922da..c4b810cb59 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -862,7 +862,8 @@ define Device/dlink_dap-2xxx
IMAGE/factory.img := append-kernel | pad-offset 6144k 160 | \
append-rootfs | wrgg-pad-rootfs | mkwrggimg | check-size
IMAGE/sysupgrade.bin := append-kernel | mkwrggimg | \
- pad-to $$$$(BLOCKSIZE) | append-rootfs | check-size | append-metadata
+ pad-to $$$$(BLOCKSIZE) | append-rootfs | wrgg-pad-rootfs | \
+ check-size | append-metadata
KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
endef