aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-07-31 22:56:29 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-10-22 21:25:18 +0200
commite9335c292003e15901ef5f665750f9493132eb28 (patch)
treea918f66cca897da04e82cb7bb3f1b0f363282c28 /target
parent8a042450d8fd4e2916fb0e87d65bbbd7e3a97130 (diff)
downloadupstream-e9335c292003e15901ef5f665750f9493132eb28.tar.gz
upstream-e9335c292003e15901ef5f665750f9493132eb28.tar.bz2
upstream-e9335c292003e15901ef5f665750f9493132eb28.zip
ath79: lzma-loader: fix & re-enable per-board CONFIG_BOARD_DEV
Back in the AR71XX days, the lzma-loader code could be customized based on the $BOARD variable. These would be passed as a compile-time -DCONFIG_BOARD_$DEVICE_MODEL flag to the compiler. Hence, the lzma-loader would be able to include device-specific fixups. Note: There's still a fixup for the TpLink TL-WR1043ND V1 found in the lzma-loader's board.c code. But since the days of AR71XX I couldn't find a forum post or bug reported. So, I left it as is to not break anything by enabling it. => If you have a TL-WR1043ND V1 and you have problem with the ethernet: let me know. Because otherwise, the fixup might simply no longer needed with ath79 and it can be removed. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 38c623bf27..768ec57044 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -27,14 +27,17 @@ define Build/loader-common
endef
define Build/loader-kernel
- $(call Build/loader-common,LOADER_DATA="$@")
+ $(call Build/loader-common, \
+ LOADER_DATA="$@" \
+ BOARD="$(DEVICE_NAME)" )
endef
define Build/loader-okli-compile
$(call Build/loader-common, \
FLASH_OFFS=$(LOADER_FLASH_OFFS) \
FLASH_MAX=$(LOADER_FLASH_MAX) \
- KERNEL_MAGIC=$(LOADER_KERNEL_MAGIC) )
+ KERNEL_MAGIC=$(LOADER_KERNEL_MAGIC) \
+ BOARD="$(DEVICE_NAME)" )
endef
# Arguments: <output name> <kernel offset>