aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2022-01-21 20:12:29 +0300
committerPetr Štetiar <ynezz@true.cz>2022-02-19 13:10:01 +0100
commite1e4cbde5ceb228e60fff1fc752cb90d9a7df2ab (patch)
tree05ee86aa9aab5e02791acc7e4effba22a985068b /target
parent2c211a901d965f9a7282ca1bf43abc66bd2fe360 (diff)
downloadupstream-e1e4cbde5ceb228e60fff1fc752cb90d9a7df2ab.tar.gz
upstream-e1e4cbde5ceb228e60fff1fc752cb90d9a7df2ab.tar.bz2
upstream-e1e4cbde5ceb228e60fff1fc752cb90d9a7df2ab.zip
x86: geode: add kmod-crypto-ebc needed for hw acceleration
Module kmod-crypto-hw-geode provides accelerated cbc(aes) and ecb(aes) but the software implementation is also needed when AES key size isn't 128 so that the operation can fall back. Add the kmod so that it would all work as expected out of the box. Tested-by: timur_davletshin Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/image/geode.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/x86/image/geode.mk b/target/linux/x86/image/geode.mk
index 6cea887926..ce5e93a2c5 100644
--- a/target/linux/x86/image/geode.mk
+++ b/target/linux/x86/image/geode.mk
@@ -1,7 +1,8 @@
define Device/generic
DEVICE_VENDOR := Generic
DEVICE_MODEL := x86/Geode
- DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-hw-geode kmod-ledtrig-gpio
+ DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-ebc kmod-crypto-hw-geode \
+ kmod-ledtrig-gpio
GRUB2_VARIANT := legacy
endef
TARGET_DEVICES += generic