aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2021-10-11 11:47:24 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:52:21 +0200
commit60f52f9b0d9dba7bcaec0be110178f0e3eadceb9 (patch)
treea52d956c8ce32c812d68e464eb88274e86a58f73 /target
parent8b7e577f76897ee44bc00a2303cbcae2a52b5ebf (diff)
downloadupstream-60f52f9b0d9dba7bcaec0be110178f0e3eadceb9.tar.gz
upstream-60f52f9b0d9dba7bcaec0be110178f0e3eadceb9.tar.bz2
upstream-60f52f9b0d9dba7bcaec0be110178f0e3eadceb9.zip
at91: add support for sama5d27-wlsom1-ek board
Add support for SAMA5D27 WLSOM1-EK board. Hardware: - SIP: SAMA5D27C-LD2G-CU including SAMA5D27 MPU and 2Gbit LPDDR2-SDRAM - MMC: one standard SD card interface - Flash: 64 Mb serial quad I/O flash memory (SST26VF064BEUIT-104I/MF) with embedded EUI-48 and EUI-64 MAC addresses - USB: one USB device, one USB host one HSIC interface - Ethernet: 1x10/100Mbps port - WiFi/BT: IEEE 802.11 b/g/n Wi-Fi plus Bluetooth (Wi-Fi/BT) module (ATWILC3000-MR110UA) - Crypto: one ATECC608B-TNGTLS secure element - Video: one LCD RGB 18-bit interface, one ISC 12-bit camera interface - Debug port: one JTAG interface, one UART interface, one WILC UART interface - Leds: one RGB LED - Buttons: start, reset, wakeup, user buttons - Expansion: one tamper connector, one mikrobus interface, 2 XPRO PTC connector - Power managament: PMIC (MCP16502) Flashing: - follow procedure at [1] [1] https://www.linux4sam.org/bin/view/Linux4SAM/Sama5d27WLSom1EKMainPage#Create_a_SD_card_with_the_demo Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91/image/sama5.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index ae34943321..9078db525f 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -87,6 +87,17 @@ define Device/microchip_sama5d27-som1-ek
endef
TARGET_DEVICES += microchip_sama5d27-som1-ek
+define Device/microchip_sama5d27-wlsom1-ek
+ $(Device/evaluation-dtb)
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D27 WSOM1 Ek
+ DEVICE_DTS := at91-sama5d27_wlsom1_ek
+ SUPPORTED_DEVICES := microchip,sama5d27-wlsom1-ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += microchip_sama5d27-wlsom1-ek
+
define Device/microchip_sama5d2-ptc-ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip