aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-31 11:21:34 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-31 11:40:15 +0200
commite496eefccca90c0b244434a11393f6f86fd9194a (patch)
tree0a0659bca02799d76ac621149c485a743c324050 /target
parent090779b24e436bb5113719eb7067c7b8151abd14 (diff)
downloadupstream-e496eefccca90c0b244434a11393f6f86fd9194a.tar.gz
upstream-e496eefccca90c0b244434a11393f6f86fd9194a.tar.bz2
upstream-e496eefccca90c0b244434a11393f6f86fd9194a.zip
mvebu: increase compat version for SolidRun ClearFog Base
When changing the Pro variant to DSA, the ethernet interface rename script was dropped by all devices to keep them in sync: be309bfd7445 ("mvebu: drop 06_set_iface_mac preinit script") Therefore, network config will be broken after upgrade for the Base variant as well. Increase the compat version and provide a message to signal that to the users. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/mvebu/cortexa9/base-files/etc/board.d/05_compat-version1
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
2 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/mvebu/cortexa9/base-files/etc/board.d/05_compat-version b/target/linux/mvebu/cortexa9/base-files/etc/board.d/05_compat-version
index dffb94de03..9304b84e7f 100755
--- a/target/linux/mvebu/cortexa9/base-files/etc/board.d/05_compat-version
+++ b/target/linux/mvebu/cortexa9/base-files/etc/board.d/05_compat-version
@@ -15,6 +15,7 @@ case "$(board_name)" in
linksys,wrt1900acs|\
linksys,wrt3200acm|\
linksys,wrt32x|\
+ solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
ucidef_set_compat_version "1.1"
;;
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index e86675eeb9..245e8a2d69 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -244,9 +244,11 @@ define Device/solidrun_clearfog-base-a1
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-base armada-388-clearfog-pro
- SUPPORTED_DEVICES += armada-388-clearfog-base
UBOOT := clearfog-u-boot-spl.kwb
BOOT_SCRIPT := clearfog
+ SUPPORTED_DEVICES += armada-388-clearfog-base
+ DEVICE_COMPAT_VERSION := 1.1
+ DEVICE_COMPAT_MESSAGE := Ethernet interface rename has been dropped
endef
TARGET_DEVICES += solidrun_clearfog-base-a1