aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 09:16:43 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 09:16:43 +0000
commit5a6268c078425a6c0452202000948251f14fa632 (patch)
tree5339cb100b15d1334cbcbab47489e13432dfbe97 /target
parent3fbffbb7b018f3ac7d9bece160d3af74ec6b9312 (diff)
downloadupstream-5a6268c078425a6c0452202000948251f14fa632.tar.gz
upstream-5a6268c078425a6c0452202000948251f14fa632.tar.bz2
upstream-5a6268c078425a6c0452202000948251f14fa632.zip
lantiq: add esi
http://patchwork.openwrt.org/patch/3703/ Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 40326
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/lantiq/base-files/etc/init.d/esi7
-rw-r--r--target/linux/lantiq/xway/target.mk2
2 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/lantiq/base-files/etc/init.d/esi b/target/linux/lantiq/base-files/etc/init.d/esi
new file mode 100755
index 0000000000..5635b5361b
--- /dev/null
+++ b/target/linux/lantiq/base-files/etc/init.d/esi
@@ -0,0 +1,7 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2013 OpenWrt.org
+
+START=19
+start() {
+ esi $(printf '%X' $((1+0x$(tr -d : </sys/class/net/eth0/address)))) 2>/dev/null || :
+}
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
index 3da4638da3..1a8bbb4bc0 100644
--- a/target/linux/lantiq/xway/target.mk
+++ b/target/linux/lantiq/xway/target.mk
@@ -5,7 +5,7 @@ FEATURES:=squashfs atm mips16
CPU_TYPE:=34kc
CPU_SUBTYPE:=dsp
-DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug atm-esi
define Target/Description
Lantiq XWAY