aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-09-23 21:01:37 +0200
committerDavid Bauer <mail@david-bauer.net>2021-09-24 12:29:22 +0200
commit5c904bcb37374d1d5f26dcb7878f869c15ad2082 (patch)
tree1b3760723a532fe33ad9c28c0a26dfe370bd57c4 /target
parentbf30ad1408f91d579f344e7798a2f03754fd21fc (diff)
downloadupstream-5c904bcb37374d1d5f26dcb7878f869c15ad2082.tar.gz
upstream-5c904bcb37374d1d5f26dcb7878f869c15ad2082.tar.bz2
upstream-5c904bcb37374d1d5f26dcb7878f869c15ad2082.zip
rockchip: fix broken squashfs sysupgrade
The rockchip platform supports squashfs SD card images. However, the resulting image is not padded to completely fill the rootfs partition. Because of that, the f2fs overlay might not be erased, resulting in uci-defaults not bing executed or the configuration not being erased, even though drop config was selected. Modify the image generation process so the image is padded to cover the entire root filesystem partition. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit b56f7407d999d29c200c8c5880655926ef9874b7)
Diffstat (limited to 'target')
-rw-r--r--target/linux/rockchip/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index f5fdff637f..e4db1e5d58 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -34,7 +34,7 @@ define Build/pine64-img
# http://opensource.rock-chips.com/wiki_Boot_option#Boot_flow
#
# U-Boot SPL expects the U-Boot ITB to be located at sector 0x4000 (8 MiB) on the MMC storage
- $(SCRIPT_DIR)/gen_image_generic.sh \
+ PADDING=1 $(SCRIPT_DIR)/gen_image_generic.sh \
$@ \
$(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \