aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
author张鹏 <sd20@qxwlan.com>2020-10-16 12:42:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-17 20:17:59 +0200
commit987d9028e12f37fcb3ca095efd6ffde6d7007469 (patch)
treeb70357d8e29e972ad31dcf12b974dd2d8154472b /target
parent27a7d071c0e0576eddeb641d1f68abe1b6205aee (diff)
downloadupstream-987d9028e12f37fcb3ca095efd6ffde6d7007469.tar.gz
upstream-987d9028e12f37fcb3ca095efd6ffde6d7007469.tar.bz2
upstream-987d9028e12f37fcb3ca095efd6ffde6d7007469.zip
ath79: add support for Qxwlan E558 v2
Qxwlan E558 v2 is based on Qualcomm QCA9558 + AR8327. Specification: - 720/600/200 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 8/16 MB of FLASH (SPI NOR) - 2T2R 2.4 GHz (QCA9558) - 3x 10/100/1000 Mbps Ethernet (one port with PoE support) - 4x miniPCIe slot (USB 2.0 bus only) - 1x microSIM slot - 5x LED (4 driven by GPIO) - 1x button (reset) - 1x 3-pos switch - 1x DC jack for main power input (9-48 V) - UART (JP5) and LEDs (J8) headers on PCB Flash instruction: 1.Using tftp mode with UART connection and original LEDE image - Configure PC with static IP 192.168.1.10 and tftp server. - Rename "openwrt-ar71xx-generic-xxx-squashfs-sysupgrade.bin" to "firmware.bin" and place it in tftp server directory. - Connect PC with one of LAN ports, power up the router and press key "Enter" to access U-Boot CLI. - Use the following commands to update the device to LEDE: run lfw - After that the device will reboot and boot to LEDE. - Wait until all LEDs stops flashing and use the router. 2.Using httpd mode with Web UI connection and original LEDE image - Configure PC with static IP 192.168.1.xxx(2-255) and tftp server. - Connect PC with one of LAN ports,press the reset button, power up the router and keep button pressed for around 6-7 seconds, until leds flashing. - Open your browser and enter 192.168.1.1,You will see the upgrade interface, select "openwrt-ar71xx-generic-xxx-squashfs- sysupgrade.bin" and click the upgrade button. - After that the device will reboot and boot to LEDE. - Wait until all LEDs stops flashing and use the router. Signed-off-by: 张鹏 <sd20@qxwlan.com> [cut out of bigger patch, keep swconfig, whitespace adjustments] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9558_qxwlan_e558-v2-16m.dts16
-rw-r--r--target/linux/ath79/dts/qca9558_qxwlan_e558-v2-8m.dts16
-rw-r--r--target/linux/ath79/dts/qca9558_qxwlan_e558.dtsi172
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ath79/image/generic.mk21
5 files changed, 230 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9558_qxwlan_e558-v2-16m.dts b/target/linux/ath79/dts/qca9558_qxwlan_e558-v2-16m.dts
new file mode 100644
index 0000000000..1df4c5e6b5
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_qxwlan_e558-v2-16m.dts
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_qxwlan_e558.dtsi"
+
+/ {
+ model = "Qxwlan E558 v2 16M";
+ compatible = "qxwlan,e558-v2-16m", "qca,qca9558";
+};
+
+&partitions {
+ partition@70000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x070000 0xf90000>;
+ };
+};
diff --git a/target/linux/ath79/dts/qca9558_qxwlan_e558-v2-8m.dts b/target/linux/ath79/dts/qca9558_qxwlan_e558-v2-8m.dts
new file mode 100644
index 0000000000..30d17d5b05
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_qxwlan_e558-v2-8m.dts
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_qxwlan_e558.dtsi"
+
+/ {
+ model = "Qxwlan E558 v2 8M";
+ compatible = "qxwlan,e558-v2-8m", "qca,qca9558";
+};
+
+&partitions {
+ partition@70000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x070000 0x790000>;
+ };
+};
diff --git a/target/linux/ath79/dts/qca9558_qxwlan_e558.dtsi b/target/linux/ath79/dts/qca9558_qxwlan_e558.dtsi
new file mode 100644
index 0000000000..99f37ac025
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_qxwlan_e558.dtsi
@@ -0,0 +1,172 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ label-mac-device = &eth0;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wlan {
+ label = "green:wlan";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ led_system: system {
+ label = "green:system";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ sig1 {
+ label = "green:sig1";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ sig2 {
+ label = "green:sig2";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pcie0 {
+ status = "okay";
+};
+
+&pcie1 {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ read-only;
+ };
+
+ pridata: partition@50000 {
+ label = "pri-data";
+ reg = <0x050000 0x010000>;
+ read-only;
+ };
+
+ art: partition@60000 {
+ label = "art";
+ reg = <0x060000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+
+ qca,ar8327-initvals = <
+ 0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+ 0x0c 0x07600000 /* PORT6 PAD MODE CTRL */
+ 0x10 0x81000080 /* POWER_ON_STRAP */
+ 0x50 0xcc35cc35 /* LED_CTRL0 */
+ 0x54 0xca35ca35 /* LED_CTRL1 */
+ 0x58 0xc935c935 /* LED_CTRL2 */
+ 0x5c 0x03ffff00 /* LED_CTRL3 */
+ 0x7c 0x0000007e /* PORT0_STATUS */
+ 0x94 0x0000007e /* PORT6 STATUS */
+ >;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ pll-data = <0x56000000 0x00000101 0x00001616>;
+
+ phy-handle = <&phy0>;
+
+ mtd-mac-address = <&pridata 0x400>;
+ mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+ status = "okay";
+
+ pll-data = <0x03000101 0x00000101 0x00001616>;
+
+ mtd-mac-address = <&pridata 0x400>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&usb_phy0 {
+ status = "okay";
+};
+
+&usb0 {
+ status = "okay";
+};
+
+&usb_phy1 {
+ status = "okay";
+};
+
+&usb1 {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 78ec5c6afe..8f528c33cd 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -285,6 +285,11 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "2:lan" "3:lan"
;;
+ qxwlan,e558-v2-8m|\
+ qxwlan,e558-v2-16m)
+ ucidef_add_switch "switch0" \
+ "0@eth1" "4:lan" "5:lan" "6@eth0" "3:wan"
+ ;;
rosinson,wr818)
ucidef_add_switch "switch0" \
"0@eth0" "1:lan" "2:lan" "3:wan"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 71dc261b2c..528a63f629 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1475,6 +1475,27 @@ define Device/qihoo_c301
endef
TARGET_DEVICES += qihoo_c301
+define Device/qxwlan_e558-v2
+ SOC := qca9558
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E558
+ DEVICE_PACKAGES := kmod-usb2
+endef
+
+define Device/qxwlan_e558-v2-16m
+ $(Device/qxwlan_e558-v2)
+ DEVICE_VARIANT := v2 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e558-v2-16m
+
+define Device/qxwlan_e558-v2-8m
+ $(Device/qxwlan_e558-v2)
+ DEVICE_VARIANT := v2 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e558-v2-8m
+
define Device/qxwlan_e750a-v4
SOC := ar9344
DEVICE_VENDOR := Qxwlan