aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-04-08 10:39:56 +0200
committerRafał Miłecki <rafal@milecki.pl>2021-04-08 13:16:14 +0200
commitcc51d9720057e76c9555a4136eceac4d039689ab (patch)
treee46870343d9b1b682141b9220121f0069e752927 /target
parent541db110bb90b6c965a71d597a14a48cd79a234a (diff)
downloadupstream-cc51d9720057e76c9555a4136eceac4d039689ab.tar.gz
upstream-cc51d9720057e76c9555a4136eceac4d039689ab.tar.bz2
upstream-cc51d9720057e76c9555a4136eceac4d039689ab.zip
bcm4908: enable Netgear R8000P bootloader image
This enables building BCM4908 "raw" image that can be flashed using bootloader web UI. It requires serial console access & stopping booting by the "Press any key to stop auto run". It's easy to build vendor like CHK image but it can't be safely flashed using vendor UI at this point. Netgear implements method called "NAND incremental flashing" that doesn't seem to flash bootfs partition as provided. Above method seems to update vmlinux.lz without updating 94908.dtb. It prevents OpenWrt kernel from booting due to incomplete DTB file. Full Netgear R8000P support can be enabled after finding a way to make vendor firmware flash OpenWrt firmware including the 94908.dtb update. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit d92a9c97bf3700e90af1d3c9157502af660365c0)
Diffstat (limited to 'target')
-rw-r--r--target/linux/bcm4908/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index 1c0781f643..015897cd99 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -48,6 +48,7 @@ define Device/Default
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
BLOCKSIZE := 128k
PAGESIZE := 2048
+ IMAGE/bin := append-ubi | bcm4908img
endef
define Device/asus_gt-ac5300
@@ -67,11 +68,10 @@ define Device/netgear_r8000p
DEVICE_VENDOR := Netgear
DEVICE_MODEL := R8000P
DEVICE_DTS := broadcom/bcm4908/bcm4906-netgear-r8000p
- IMAGES := chk
+ IMAGES := bin
IMAGE/chk := append-ubi | bcm4908img | netgear-chk
NETGEAR_BOARD_ID := U12H359T00_NETGEAR
NETGEAR_REGION := 1
- BROKEN := y
endef
TARGET_DEVICES += netgear_r8000p