aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-13 19:20:57 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 19:46:45 +0100
commitc6a8a23ea2ed4e92f8e96d783fb672d167cfb611 (patch)
treeb413dd1eeb4de3438c4020aca33fd84ce785d629 /target
parentd2424d4b21c88f1bf262665389d217d3cc8ff416 (diff)
downloadupstream-c6a8a23ea2ed4e92f8e96d783fb672d167cfb611.tar.gz
upstream-c6a8a23ea2ed4e92f8e96d783fb672d167cfb611.tar.bz2
upstream-c6a8a23ea2ed4e92f8e96d783fb672d167cfb611.zip
xburst: remove hack to determine entry point
xburst has CONFIG_BOOT_RAW set, so jumping to the load address is valid Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/xburst/image/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 0853607506..ff25fbebcc 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -20,15 +20,10 @@ endif
UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
-define kernel_entry
-0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
-endef
-
-
define MkImageGzip
gzip -9n -c $(1) > $(1).gz
mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
- -e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e 0x80010000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(1).gz $(2)
endef