aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2020-03-02 22:03:09 +0100
committerRafał Miłecki <rafal@milecki.pl>2020-04-07 15:48:22 +0200
commita89731ad7aa4c9d357947381458735f861b85db7 (patch)
tree9346b8ebd426b6039da6ba9f7612852386504e08 /target
parent36373c5ddb1b6fc81fa239a1f898c5abc3f24f40 (diff)
downloadupstream-a89731ad7aa4c9d357947381458735f861b85db7.tar.gz
upstream-a89731ad7aa4c9d357947381458735f861b85db7.tar.bz2
upstream-a89731ad7aa4c9d357947381458735f861b85db7.zip
bcm53xx: fix ASUS firmwares to use vendor format
Image building process was missing "asus-trx" step which resulted in raw TRX files (without ASUS footer with device id). Fixes: 0b9de8daa70e ("bcm53xx: add profiles for all other (SoftMAC) devices") Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 0493d57e04774d47921a7d2014b567455d5dc16b)
Diffstat (limited to 'target')
-rw-r--r--target/linux/bcm53xx/image/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4f18a9c0a8..3946b47032 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -79,7 +79,7 @@ endef
define Build/asus-trx
$(STAGING_DIR_HOST)/bin/asustrx \
- -p $(PRODUCTID) -i $@ -o $@.new
+ -p $(ASUS_PRODUCTID) -i $@ -o $@.new
mv $@.new $@
endef
@@ -107,8 +107,10 @@ define Build/seama-nand
-i $@.entity
endef
-DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
+DEVICE_VARS += ASUS_PRODUCTID
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
+DEVICE_VARS += SIGNATURE
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
DEVICE_VARS += LUXUL_BOARD
IEEE8021X := wpad-basic
@@ -143,26 +145,34 @@ define Device/asus
endef
define Device/asus-rt-ac56u
+ $(call Device/asus)
DEVICE_TITLE := Asus RT-AC56U
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC56U
endef
TARGET_DEVICES += asus-rt-ac56u
define Device/asus-rt-ac68u
+ $(call Device/asus)
DEVICE_TITLE := Asus RT-AC68U
DEVICE_PACKAGES := $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC68U
endef
TARGET_DEVICES += asus-rt-ac68u
define Device/asus-rt-ac87u
+ $(call Device/asus)
DEVICE_TITLE := Asus RT-AC87U
DEVICE_PACKAGES := $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC87U
endef
TARGET_DEVICES += asus-rt-ac87u
define Device/asus-rt-n18u
+ $(call Device/asus)
DEVICE_TITLE := Asus RT-N18U
DEVICE_PACKAGES := $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-N18U
endef
TARGET_DEVICES += asus-rt-n18u