aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-03-26 01:10:02 +0100
committerDavid Bauer <mail@david-bauer.net>2020-03-26 01:34:30 +0100
commit81264ebb51991aa2d17489852854e3b5ec3f514d (patch)
treea82b109491a18e7c911a01fb8ce7cf23d7804a7b /target
parent39405644d5b97796a633315e0ce7b65f8a1eb3ac (diff)
downloadupstream-81264ebb51991aa2d17489852854e3b5ec3f514d.tar.gz
upstream-81264ebb51991aa2d17489852854e3b5ec3f514d.tar.bz2
upstream-81264ebb51991aa2d17489852854e3b5ec3f514d.zip
brcm2708: fix build failure
Build of the brcm2708 subtarget currently fails with the following error message: arch/arm/lib/memset_rpi.S: Assembler messages: arch/arm/lib/memset_rpi.S:65: Error: garbage following instruction -- `orr DAT0,DAT0,lsl#8' arch/arm/lib/memset_rpi.S:67: Error: garbage following instruction -- `orr DAT0,DAT0,lsl#16' scripts/Makefile.build:427: recipe for target 'arch/arm/lib/memset_rpi.o' failed Using the assembly notation from master fixes this error. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0061-Improve-__copy_to_user-and-__copy_from_user-performa.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm2708/patches-4.14/950-0061-Improve-__copy_to_user-and-__copy_from_user-performa.patch b/target/linux/brcm2708/patches-4.14/950-0061-Improve-__copy_to_user-and-__copy_from_user-performa.patch
index d7b04c9efd..b8f7de202d 100644
--- a/target/linux/brcm2708/patches-4.14/950-0061-Improve-__copy_to_user-and-__copy_from_user-performa.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0061-Improve-__copy_to_user-and-__copy_from_user-performa.patch
@@ -1313,9 +1313,9 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
+ DAT2 .req ip
+ DAT3 .req lr
+
-+ orr DAT0, DAT0, lsl #8
++ orr DAT0, DAT0, DAT0, lsl #8
+ push {S, lr}
-+ orr DAT0, DAT0, lsl #16
++ orr DAT0, DAT0, DAT0, lsl #16
+ mov DAT1, DAT0
+
+ /* See if we're guaranteed to have at least one 16-byte aligned 16-byte write */