aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-08-13 11:38:17 -1000
committerDaniel Golle <daniel@makrotopia.org>2019-08-22 21:19:04 +0200
commit8bf8de95a20d9fee54bbd579832c578c62cbc901 (patch)
treedbcc748e161790c780b44229ab5c95e5bb1b2bb2 /target
parent7d300326ee84e514fe9e509580e7942098d507b2 (diff)
downloadupstream-8bf8de95a20d9fee54bbd579832c578c62cbc901.tar.gz
upstream-8bf8de95a20d9fee54bbd579832c578c62cbc901.tar.bz2
upstream-8bf8de95a20d9fee54bbd579832c578c62cbc901.zip
imagebuilder: fix `make info` for empty SUPPORTED_DEVICES
For x86/64 (maybe more) target the SUPPORTED_DEVICES variable is empty which causes the `&&` junction to fail, producing a non zero exit code. Tested-by: Paul Spooren <mail@aparcar.org> Fixed-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 07926d7def59e5684b488e9b614342edc19e7eb2)
Diffstat (limited to 'target')
-rw-r--r--target/imagebuilder/files/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 22b2731358..15b3d5c35c 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -76,7 +76,8 @@ USER_PROFILE ?= $(firstword $(PROFILE_NAMES))
PROFILE_LIST = $(foreach p,$(PROFILE_NAMES), \
echo '$(patsubst DEVICE_%,%,$(p)):'; $(if $($(p)_NAME),echo ' $(subst ','"'"',$($(p)_NAME))'; ) \
echo ' Packages: $($(p)_PACKAGES)'; echo ' hasImageMetadata: $($(p)_HAS_IMAGE_METADATA)'; \
- [ "$($(p)_SUPPORTED_DEVICES)" ] && echo ' SupportedDevices: $($(p)_SUPPORTED_DEVICES)'; )
+ $(if $($(p)_SUPPORTED_DEVICES),echo ' SupportedDevices: $($(p)_SUPPORTED_DEVICES)';) )
+
.profiles.mk: .targetinfo
@$(SCRIPT_DIR)/target-metadata.pl profile_mk $< '$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET))' > $@