aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorKarl Vogel <karl.vogel@gmail.com>2018-11-29 09:07:21 +0100
committerJo-Philipp Wich <jo@mein.io>2018-11-29 11:36:58 +0100
commitcc8e8750397b721438e312d492433014d46b3a0c (patch)
tree205937a26586cda6066f4ca2c92dd0fcc58385ec /target
parenta8b292afe6d2a9ff2186a98df6d4ab0eb47fcba7 (diff)
downloadupstream-cc8e8750397b721438e312d492433014d46b3a0c.tar.gz
upstream-cc8e8750397b721438e312d492433014d46b3a0c.tar.bz2
upstream-cc8e8750397b721438e312d492433014d46b3a0c.zip
sdk: find kernel modules when KDIR is a symlink
The find statement would not return any results if the KDIR_BASE pointed to a symlink. Ran into this issue due to a custom Kernel/Prepare that was installing a symlink to the kernel directory. The extra slash at the end fixes this scenario and does no harm for targets that have a proper KDIR. Signed-off-by: Karl Vogel <karl.vogel@gmail.com> (cherry picked from commit ae980458abf8299d614f4b34add32e18d054378d)
Diffstat (limited to 'target')
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index a9df8be7d2..95ac3be197 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -83,7 +83,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
$(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
- `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+ `cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \
`cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
-type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
$(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \