aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-10-18 09:29:50 +0200
committerFelix Fietkau <nbd@nbd.name>2016-10-18 09:30:57 +0200
commita92f57599cea2f1cd3db88b49031b2de1eb3859e (patch)
tree49dbd7e30a9bfd7a4d07b5e3e5901ce25fe22431 /target
parentf5aa4590433638e6b2c191412fa802ae5a64cdc9 (diff)
downloadupstream-a92f57599cea2f1cd3db88b49031b2de1eb3859e.tar.gz
upstream-a92f57599cea2f1cd3db88b49031b2de1eb3859e.tar.bz2
upstream-a92f57599cea2f1cd3db88b49031b2de1eb3859e.zip
ipq806x: add back end-of-UBI marker for a few factory images (FS#228)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 7703a62339..b74f1a77c2 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -70,6 +70,7 @@ define Device/DniImage
KERNEL_NAME := zImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
+ UBINIZE_OPTS := -E 5
IMAGES := factory.img sysupgrade.tar
IMAGE/factory.img := append-kernel | append-ubi | netgear-dni
IMAGE/sysupgrade.tar = sysupgrade-tar
@@ -154,6 +155,7 @@ define Device/EA8500
KERNEL = kernel-bin | append-dtb | uImage none | append-file $(KDIR)/root.dummy
PROFILES += $$(DEVICE_NAME)
BOARD_NAME := ea8500
+ UBINIZE_OPTS := -E 5
IMAGES := factory.bin sysupgrade.tar
IMAGE/factory.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi
IMAGE/sysupgrade.tar := sysupgrade-tar