aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAubrey McIntosh, PhD <aubrey.mcintosh@utexas.edu>2018-09-04 01:40:10 -0500
committerPetr Štetiar <ynezz@true.cz>2019-04-11 22:22:10 +0200
commit9c4fa1bb5bfdc756a3fbfce6360fddfdb67f083a (patch)
tree322ba63d4d7bcf476b6e732849b9a69930e7201c /target
parent6c81f5fac62196c51d974f681b480414bda7b202 (diff)
downloadupstream-9c4fa1bb5bfdc756a3fbfce6360fddfdb67f083a.tar.gz
upstream-9c4fa1bb5bfdc756a3fbfce6360fddfdb67f083a.tar.bz2
upstream-9c4fa1bb5bfdc756a3fbfce6360fddfdb67f083a.zip
ar71xx: Remove ath10k packages from archer-c7-v1 (fixes FS#1743)
ath10k_pci driver crashes once loaded and causes boot loops on this device as 5GHz radio QCA9880-AR1A shipped with this router is broken. It's not possible to fix this problem in software, miniPCIe radio has to be replaced. We could've probably fixed crashing of the ath10k driver by reverting following upstream commit: commit 1a7fecb766c83dace747f42b25bbb544b00a0163 Author: Michal Kazior <michal.kazior@tieto.com> Date: Sat Jan 24 12:14:48 2015 +0200 ath10k: reset chip before reading chip_id in probe but it's not worth the effort as it wouldn't make that 5GHz radio usable anyway. So it seems more convenient to just remove the crashing driver and provide bootable images, as I believe, that a router that is working but degraded is better than a router that will not work. For details please see discussions in PR[1] and in FS#1743[2]. 1. https://github.com/openwrt/openwrt/pull/1349 2. https://bugs.openwrt.org/index.php?do=details&task_id=1743 Reviewed-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> Signed-off-by: Aubrey McIntosh, PhD <aubrey.mcintosh@utexas.edu> [subject and commit message tweaks] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index 338b2db2d6..86d1aa41e3 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -87,7 +87,7 @@ TARGET_DEVICES += archer-c5-v1
define Device/archer-c7-v1
$(Device/tplink-8mlzma)
DEVICE_TITLE := TP-LINK Archer C7 v1
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME := ARCHER-C7
DEVICE_PROFILE := ARCHERC7
TPLINK_HWID := 0x75000001