aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-01 17:28:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-01 17:28:47 +0000
commit21b15ddda5b92e0546ae611629c0862a7be40426 (patch)
tree82e41c2fbd7e9982fa85dc6bd691b0413cbfdff2 /target
parentd158dfc607c185f95cda91fa546f3f33d53f33a4 (diff)
downloadupstream-21b15ddda5b92e0546ae611629c0862a7be40426.tar.gz
upstream-21b15ddda5b92e0546ae611629c0862a7be40426.tar.bz2
upstream-21b15ddda5b92e0546ae611629c0862a7be40426.zip
mpc85xx: image: fix building of multiple dtb files
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35436
Diffstat (limited to 'target')
-rw-r--r--target/linux/mpc85xx/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index a5d1acbd5c..9906817636 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -15,7 +15,9 @@ endef
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
- $(foreach dts,$(DTS_TARGETS),$(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(LINUX_DIR)/arch/powerpc/boot/dts/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt)
+ $(foreach dts,$(DTS_TARGETS),
+ $(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(LINUX_DIR)/arch/powerpc/boot/dts/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt
+ )
endef
define Image/Build/ext2
*/ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
From 228a56f5c3e7b796cedb9cf7e55c2bf16c534269 Mon Sep 17 00:00:00 2001
From: Phil Elwell <phil@raspberrypi.org>
Date: Wed, 24 Jan 2018 20:00:48 +0000
Subject: [PATCH 171/454] overlays: Allow multiple pps-gpio instantiations

See: https://github.com/raspberrypi/linux/issues/2352

Signed-off-by: Phil Elwell <phil@raspberrypi.org>
---
 arch/arm/boot/dts/overlays/pps-gpio-overlay.dts | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

--- a/arch/arm/boot/dts/overlays/pps-gpio-overlay.dts
+++ b/arch/arm/boot/dts/overlays/pps-gpio-overlay.dts
@@ -6,7 +6,7 @@
 	fragment@0 {
 		target-path = "/";
 		__overlay__ {
-			pps: pps {
+			pps: pps@12 {
 				compatible = "pps-gpio";
 				pinctrl-names = "default";
 				pinctrl-0 = <&pps_pins>;
@@ -19,7 +19,7 @@
 	fragment@1 {
 		target = <&gpio>;
 		__overlay__ {
-			pps_pins: pps_pins {
+			pps_pins: pps_pins@12 {
 				brcm,pins =     <18>;
 				brcm,function = <0>;    // in
 				brcm,pull =     <0>;    // off
@@ -29,7 +29,9 @@
 
 	__overrides__ {
 		gpiopin = <&pps>,"gpios:4",
-			  <&pps_pins>,"brcm,pins:0";
+			  <&pps>,"reg:0",
+			  <&pps_pins>,"brcm,pins:0",
+			  <&pps_pins>,"reg:0";
 		assert_falling_edge = <&pps>,"assert-falling-edge?";
 	};
 };