aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorYuheiOKAWA <tochiro.srchack@gmail.com>2016-10-10 10:24:42 +0900
committerJohn Crispin <john@phrozen.org>2016-10-15 11:36:51 +0200
commit4050cfebdaa001d498c396f24dd67771541b710e (patch)
treee7f4f574a91e63f5f4079aecbf0781fb20eb0839 /target
parent8a2a20e71e2909f84dab47e51dfda9e292a6c1ae (diff)
downloadupstream-4050cfebdaa001d498c396f24dd67771541b710e.tar.gz
upstream-4050cfebdaa001d498c396f24dd67771541b710e.tar.bz2
upstream-4050cfebdaa001d498c396f24dd67771541b710e.zip
ramips: add support for Planex VR500.
SOC: MT7621A RAM: 256MiB NOR: MX25L51245G Non Wireless Router. Issue: soft reboot problem. SPI Flash do not exit 4byte address mode. Signed-off-by: Yuhei Okawa <tochiro.srchack@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/VR500.dts92
-rw-r--r--target/linux/ramips/image/mt7621.mk8
7 files changed, 112 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index e14448e3f2..4b66694ed9 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -146,7 +146,8 @@ mzk-ex300np)
;;
dir-810l|\
mzk-750dhp|\
-mzk-dp150n)
+mzk-dp150n|\
+vr500)
ucidef_set_led_default "power" "power" "$board:green:power" "1"
;;
dir-860l-b1)
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 0400e58cda..99c90e4590 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -85,6 +85,7 @@ ramips_setup_interfaces()
psg1218|\
sap-g3200u3|\
sk-wb8|\
+ vr500|\
wf-2881|\
whr-300hp2|\
whr-600d|\
@@ -354,6 +355,10 @@ ramips_setup_macs()
lan_mac=$(mtd_get_mac_ascii u-boot-env LAN_MAC_ADDR)
wan_mac=$(mtd_get_mac_ascii u-boot-env WAN_MAC_ADDR)
;;
+ vr500)
+ lan_mac=$(mtd_get_mac_binary factory 57344)
+ wan_mac=$(mtd_get_mac_binary factory 57350)
+ ;;
w306r-v20)
lan_mac=$(cat /sys/class/net/eth0/address)
wan_mac=$(macaddr_add "$lan_mac" 5)
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 67dcf99a00..84459a5c01 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -29,6 +29,7 @@ get_status_led() {
nbg-419n|\
nbg-419n2|\
pwh2004|\
+ vr500|\
wnce2001|\
wndr3700v5|\
x5|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index d57c1cf922..526a5ae669 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -442,6 +442,9 @@ ramips_board_detect() {
*"VoCore")
name="vocore"
;;
+ *"VR500")
+ name="vr500"
+ ;;
*"W150M")
name="w150m"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 806c1a0e8c..9c49c8070d 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -128,6 +128,7 @@ platform_check_image() {
ur-336un|\
v22rw-2x2|\
vocore|\
+ vr500|\
w150m|\
w306r-v20|\
w502u|\
diff --git a/target/linux/ramips/dts/VR500.dts b/target/linux/ramips/dts/VR500.dts
new file mode 100644
index 0000000000..3cddce6fbe
--- /dev/null
+++ b/target/linux/ramips/dts/VR500.dts
@@ -0,0 +1,92 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+/ {
+ compatible = "ralink,mt7621-eval-board", "ralink,mt7621-soc";
+ model = "Planex VR500";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x10000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ power {
+ label = "vr500:green:power";
+ gpios = <&gpio1 13 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 15 1>;
+ linux,code = <0x198>;
+ };
+ };
+};
+
+&xhci {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3fb0000>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "uart2", "uart3", "rgmii2", "sdhci";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&pcie {
+ status = "disabled";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 323f08ddbc..acaafc0a73 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -182,6 +182,14 @@ define Device/sk-wb8
endef
TARGET_DEVICES += sk-wb8
+define Device/vr500
+ DTS := VR500
+ IMAGE_SIZE := 66453504
+ DEVICE_TITLE := Planex VR500
+ DEVICE_PACKAGES := kmod-usb3
+endef
+TARGET_DEVICES += vr500
+
# FIXME: is this still needed?
define Image/Prepare
#define Build/Compile