aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-19 17:46:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-19 17:46:37 +0000
commit1a376e9f1ce93b3fbe24aa875a7f4c64bc997b5d (patch)
tree0b1b3d79a2f98e8d15648c218a0dcba8cc448885 /target
parent226db606272aff254ec76e973e78a1ef961746a1 (diff)
downloadupstream-1a376e9f1ce93b3fbe24aa875a7f4c64bc997b5d.tar.gz
upstream-1a376e9f1ce93b3fbe24aa875a7f4c64bc997b5d.tar.bz2
upstream-1a376e9f1ce93b3fbe24aa875a7f4c64bc997b5d.zip
x86_64: use default block2mtd timeout of 5s
If the underlying block device is a USB device it might require some time to settle, observed when booting a squashfs image from sd card on an Alix APU board. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 42966
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86_64/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86_64/image/Makefile b/target/linux/x86_64/image/Makefile
index aacdab0ff6..e8d9ac1158 100644
--- a/target/linux/x86_64/image/Makefile
+++ b/target/linux/x86_64/image/Makefile
@@ -55,15 +55,15 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
endef
define Image/Build/grub2