aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-16 07:50:55 +0100
committerJo-Philipp Wich <jo@mein.io>2017-03-01 20:37:37 +0100
commit657e3ce8a290758b05e212fea2fc6657badb6e98 (patch)
tree6c1d1e3783251814f666af37f32f8adac572b273 /target
parent0f2757dce4f555e53e80e8238810c9419336758b (diff)
downloadupstream-657e3ce8a290758b05e212fea2fc6657badb6e98.tar.gz
upstream-657e3ce8a290758b05e212fea2fc6657badb6e98.tar.bz2
upstream-657e3ce8a290758b05e212fea2fc6657badb6e98.zip
arc770: only calculate entry point address when necessary
$(eval) runs even during prereq check, which can cause bogus error messages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/arc770/image/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/target/linux/arc770/image/Makefile b/target/linux/arc770/image/Makefile
index f52f84017d..260757845e 100644
--- a/target/linux/arc770/image/Makefile
+++ b/target/linux/arc770/image/Makefile
@@ -10,9 +10,7 @@ include $(INCLUDE_DIR)/image.mk
# On ARC initramfs is put before entry point and so entry point moves
# in memory from build to built. Thus we need to extract EP from vmlinux
# every time before generation of uImage.
-define Build/calculate-ep
- $(eval KERNEL_ENTRY=$(shell $(KERNEL_CROSS)readelf -h $(1) | grep "Entry point address" | grep -o 0x.*))
-endef
+kernel_ep = `$(KERNEL_CROSS)readelf -h $(1) | grep "Entry point address" | grep -o 0x.*`
define Build/patch-dtb
$(STAGING_DIR_HOST)/bin/patch-dtb $@ $(DTS_DIR)/$(DEVICE_DTS).dtb
@@ -69,9 +67,8 @@ endef
define Image/BuildKernel
# Build unified uImage
- $(call Build/calculate-ep, $(KDIR)/vmlinux.elf)
$(call Image/BuildKernel/MkuImage, \
- none, $(KERNEL_LOADADDR), $(KERNEL_ENTRY), \
+ none, $(KERNEL_LOADADDR),$(call kernel_ep,$(KDIR)/vmlinux.elf) , \
$(KDIR)/vmlinux, \
$(BIN_DIR)/$(IMG_PREFIX)-uImage \
)