aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
commit7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57 (patch)
tree57e890075610ad4408a6fa4b478be0f1eb678e2a /target
parentac73de1e9395e3f8858693f368eff16fdd53f307 (diff)
downloadupstream-7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57.tar.gz
upstream-7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57.tar.bz2
upstream-7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57.zip
Use find -exec instead of xargs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/imagebuilder/Makefile4
-rw-r--r--target/sdk/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 0cbbfa2835..3d830bbc2d 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -33,8 +33,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
$(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
-cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
- find $(IB_BUILD_DIR) -name .svn | xargs rm -rf
- find $(IB_BUILD_DIR) -name CVS | xargs rm -rf
+ find $(IB_BUILD_DIR) -name .svn -exec rm -rf {} \;
+ find $(IB_BUILD_DIR) -name CVS -exec rm -rf {} \;
(cd $(BUILD_DIR); \
tar cfj $@ $(IB_NAME); \
)
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d65b934c95..3cae4b3842 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -35,8 +35,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
$(CP) ./files/package/rules.mk $(SDK_BUILD_DIR)/package/
echo OPENWRTVERSION:=$(OPENWRTVERSION) > $(SDK_BUILD_DIR)/.version.mk
rm -rf $(SDK_BUILD_DIR)/staging_dir*/ccache
- find $(SDK_BUILD_DIR) -name .svn | xargs rm -rf
- find $(SDK_BUILD_DIR) -name CVS | xargs rm -rf
+ find $(SDK_BUILD_DIR) -name .svn -exec rm -rf {} \;
+ find $(SDK_BUILD_DIR) -name CVS -exec rm -rf {} \;
(cd $(BUILD_DIR); \
tar cfj $@ $(SDK_NAME); \
)