aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-24 22:13:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-24 22:13:17 +0000
commit4fc7ff5ff76423c087d33000792e03007ad84efb (patch)
tree296ee93e87b9ff43cf83d38e06eb570627d11d12 /target
parentf606c115e560241b81225c4c56833c14367feda4 (diff)
downloadupstream-4fc7ff5ff76423c087d33000792e03007ad84efb.tar.gz
upstream-4fc7ff5ff76423c087d33000792e03007ad84efb.tar.bz2
upstream-4fc7ff5ff76423c087d33000792e03007ad84efb.zip
ep93xx: remove obsolete kernel version check
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44112 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ep93xx/modules.mk8
1 files changed, 1 insertions, 7 deletions
diff --git a/target/linux/ep93xx/modules.mk b/target/linux/ep93xx/modules.mk
index 429546690f..07726c9509 100644
--- a/target/linux/ep93xx/modules.mk
+++ b/target/linux/ep93xx/modules.mk
@@ -39,18 +39,12 @@ endef
$(eval $(call KernelPackage,input-keyboard-ep93xx))
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
-SND_EP93XX_SOC_DIR:=cirrus
-else
-SND_EP93XX_SOC_DIR:=ep93xx
-endif
-
define KernelPackage/sound-soc-ep93xx
SUBMENU:=$(SOUND_MENU)
TITLE:=EP93xx SoC sound support
DEPENDS:=@TARGET_ep93xx +kmod-sound-core +kmod-sound-soc-core
KCONFIG:=CONFIG_SND_EP93XX_SOC
- FILES:=$(LINUX_DIR)/sound/soc/$(SND_EP93XX_SOC_DIR)/snd-soc-ep93xx.ko
+ FILES:=$(LINUX_DIR)/sound/soc/cirrus/snd-soc-ep93xx.ko
AUTOLOAD:=$(call AutoLoad,57,snd-soc-ep93xx)
endef