aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-08-06 10:30:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-08-06 10:30:21 +0000
commit56e3a786b425fc9d604ee4561243e23960ef8fcc (patch)
tree1b9cc4f7ed42bf3a5ff5f554d89a66abdd770484 /target
parent55453848364d75a9a04ecfadbcef50658f141e03 (diff)
downloadupstream-56e3a786b425fc9d604ee4561243e23960ef8fcc.tar.gz
upstream-56e3a786b425fc9d604ee4561243e23960ef8fcc.tar.bz2
upstream-56e3a786b425fc9d604ee4561243e23960ef8fcc.zip
ar71xx: update Carambola2 platform data
Change list: * Remove button info on GPIO12, there is no button there. * Remove nvram mtd partition, as it's not used for anything, saves 64k for user data. Tested building for carambola2 target. Signed-off-by: Mantas Pucka <mantas@8devices.com> Backport of r41993 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42013 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-carambola2.c9
-rw-r--r--target/linux/ar71xx/image/Makefile2
2 files changed, 1 insertions, 10 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-carambola2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-carambola2.c
index e7bc861e50..babe101141 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-carambola2.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-carambola2.c
@@ -25,7 +25,6 @@
#define CARAMBOLA2_GPIO_LED_ETH1 13
#define CARAMBOLA2_GPIO_BTN_JUMPSTART 11
-#define CARAMBOLA2_GPIO_BTN_RESET 12
#define CARAMBOLA2_KEYS_POLL_INTERVAL 20 /* msecs */
#define CARAMBOLA2_KEYS_DEBOUNCE_INTERVAL (3 * CARAMBOLA2_KEYS_POLL_INTERVAL)
@@ -60,14 +59,6 @@ static struct gpio_keys_button carambola2_gpio_keys[] __initdata = {
.gpio = CARAMBOLA2_GPIO_BTN_JUMPSTART,
.active_low = 1,
},
- {
- .desc = "reset button",
- .type = EV_KEY,
- .code = KEY_RESTART,
- .debounce_interval = CARAMBOLA2_KEYS_DEBOUNCE_INTERVAL,
- .gpio = CARAMBOLA2_GPIO_BTN_RESET,
- .active_low = 1,
- }
};
static void __init carambola2_common_setup(void)
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2377ad3d54..31b4db0dbd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -248,7 +248,7 @@ ap96_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),17
ap113_mtd_layout=mtdparts=spi0.0:64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
ap121_mtdlayout_2M=mtdparts=spi0.0:64k(u-boot)ro,1216k(rootfs),704k(kernel),64k(art)ro,1920k@0x10000(firmware)
ap121_mtdlayout_4M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2752k(rootfs),896k(kernel),64k(nvram),64k(art)ro,3648k@0x50000(firmware)
-carambola2_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmware),64k(nvram),64k(art)ro
+carambola2_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
ap132_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),6400k(rootfs),64k(art),7808k@0x50000(firmware)
ap135_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
ap136_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(mib0),64k(art)ro,7744k@0x50000(firmware)