aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-09-21 11:47:44 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-09-21 11:47:44 +0000
commitef2431c8d9e77ee0e28edabbecce4ec8a86507fa (patch)
treea232b66e9fb5f0d6777e0d0e5e413564cee30a64 /target
parentffbdaf8ec838d441d51de5fa1df5900f4093758c (diff)
downloadupstream-ef2431c8d9e77ee0e28edabbecce4ec8a86507fa.tar.gz
upstream-ef2431c8d9e77ee0e28edabbecce4ec8a86507fa.tar.bz2
upstream-ef2431c8d9e77ee0e28edabbecce4ec8a86507fa.zip
ar71xx: create image for the TP-Link TL-WR743ND v1
Same hardware as WR741ND but with PoE support. Signed-off-by: Paul Fertser <fercerpav@gmail.com> SVN-Revision: 28271
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile5
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index f5a7a24a93..c770d49151 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -84,6 +84,17 @@ endef
$(eval $(call Profile,TLWR740NV3))
+define Profile/TLWR743NDV1
+ NAME:=TP-LINK TL-WR743ND v1
+ PACKAGES:=
+endef
+
+define Profile/TLWR743NDV1/Description
+ Package set optimized for the TP-LINK TL-WR743ND v1.
+endef
+
+$(eval $(call Profile,TLWR743NDV1))
+
define Profile/TLWR841NV15
NAME:=TP-LINK TL-WR841N v1.5
PACKAGES:=
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d808a1d8aa..e4163b33e5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -596,6 +596,10 @@ define Image/Build/Profile/TLWR740NV3
$(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v3,$(tlwe740nv3_cmdline),TL-WR740Nv3)
endef
+define Image/Build/Profile/TLWR743NDV1
+ $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr743nd-v1,$(tlwe741ndv1_cmdline),TL-WR743NDv1)
+endef
+
tlwr841nv15_cmdline=board=TL-WR841N-v1.5 console=ttyS0,115200
define Image/Build/Profile/TLWR841NV15
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,$(tlwr841nv15_cmdline),TL-WR841Nv1.5)
@@ -709,6 +713,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR741NDV1,$(1))
$(call Image/Build/Profile/TLWR740NV1,$(1))
$(call Image/Build/Profile/TLWR740NV3,$(1))
+ $(call Image/Build/Profile/TLWR743NDV1,$(1))
$(call Image/Build/Profile/TLWR841NV15,$(1))
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))