aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-11-22 12:50:24 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-28 00:45:57 +0100
commite59a6c8d4c5432ac22644ac06b48b179bd82b0b7 (patch)
tree02e5bc52943aa8c56b3bfa4f30baf06448bfa75e /target
parent4cd533411e55f0144a0040644ddcb58702097004 (diff)
downloadupstream-e59a6c8d4c5432ac22644ac06b48b179bd82b0b7.tar.gz
upstream-e59a6c8d4c5432ac22644ac06b48b179bd82b0b7.tar.bz2
upstream-e59a6c8d4c5432ac22644ac06b48b179bd82b0b7.zip
apm821xx: switch MyBook Live's recovery images to multi-file
This patch converts the MyBook Live's recovery image to utilize the multi-image method which integrates the device-tree binary directly into the image. The new initramfs can be loaded through the MyBook Live's U-boot in the following way: => setenv ipaddr 192.168.1.1 => setenv serverip 192.168.1.2 => sata init; run addtty; tftp $kernel_addr_r wd_mybooklive-initramfs.bin; bootm Waiting for PHY auto negotiation to complete... done ENET Speed is 1000 Mbps - FULL duplex connection (EMAC0) Using ppc_4xx_eth0 device TFTP from server 192.168.1.2; our IP address is 192.168.1.1 Filename 'wd_mybooklive-initramfs.bin'. Load address: 0x1000000 Loading: ################################################ [...] done [...] Booting kernel from Legacy Image at 01000000 ... Image Name: initramfs Image Type: PowerPC Linux Multi-File Image (gzip compressed) [...] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index a808a6342c..e28a48b087 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -228,7 +228,7 @@ define Device/wd_mybooklive
BLOCKSIZE := 1k
DTB_SIZE := 16384
KERNEL := kernel-bin | dtb | gzip | uImage gzip
- KERNEL_INITRAMFS := kernel-bin | dtb | gzip | uImage gzip
+ KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
BOOT_SIZE := 8
IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
DEVICE_DTB := apollo3g.dtb