aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-02-08 12:58:25 +0100
committerDavid Bauer <mail@david-bauer.net>2020-02-16 15:36:29 +0100
commitd2b8ccb1c04def81224da6f42f644c7d239b9986 (patch)
tree29ba990cb0f9f2e38ff97484a221ce94a9f511f8 /target
parentae35ff576764fb68b84fcac070e5d2b1ccb4966d (diff)
downloadupstream-d2b8ccb1c04def81224da6f42f644c7d239b9986.tar.gz
upstream-d2b8ccb1c04def81224da6f42f644c7d239b9986.tar.bz2
upstream-d2b8ccb1c04def81224da6f42f644c7d239b9986.zip
ath79: add support for Siemens WS-AP3610
Hardware -------- SoC: Atheros AR7161 RAM: Samsung K4H511638D-UCCC 2x 64M DDR1 SPI: Micron M25P128 (16M) WiFi: Atheros AR9160 bgn Atheros AR9160 an ETH: Broadcom BCM5481 LED: Power (Green/Red) ETH (Green / Blue / Yellow) (PHY-controlled) WiFi 5 (Green / Blue) WiFi 2 (Green / Blue) BTN: Reset Serial: Cisco-Style RJ45 - 115200 8N1 Installation ------------ 1. Download the OpenWrt initramfs-image. Place it into a TFTP server root directory and rename it to 1401A8C0.img. Configure the TFTP server to listen at 192.168.1.66/24. 2. Connect the TFTP server to the access point. 3. Connect to the serial console of the access point. Attach power and interrupt the boot procedure when prompted (bootdelay is 1 second). 4. Configure the U-Boot environment for booting OpenWrt from Ram and flash: $ setenv boot_openwrt 'setenv bootargs; bootm 0xbf080000' $ setenv ramboot_openwrt 'setenv serverip 192.168.1.66; tftpboot; bootm' $ saveenv 5. Load OpenWrt into memory: $ run ramboot_openwrt Wait for the image to boot. 6. Transfer the OpenWrt sysupgrade image to the device. Write the image to flash using sysupgrade: $ sysupgrade -n /path/to/openwrt-sysuograde.bin Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar7161_siemens_ws-ap3610.dts186
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac3
-rw-r--r--target/linux/ath79/generic/base-files/lib/preinit/10_fix_eth_mac.sh13
-rw-r--r--target/linux/ath79/generic/config-default1
-rw-r--r--target/linux/ath79/image/generic.mk14
6 files changed, 218 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar7161_siemens_ws-ap3610.dts b/target/linux/ath79/dts/ar7161_siemens_ws-ap3610.dts
new file mode 100644
index 0000000000..8e0a80cb32
--- /dev/null
+++ b/target/linux/ath79/dts/ar7161_siemens_ws-ap3610.dts
@@ -0,0 +1,186 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar7100.dtsi"
+
+/ {
+ compatible = "siemens,ws-ap3610", "qca,ar7161";
+ model = "Siemens WS-AP3610";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ aliases {
+ led-boot = &led_power_green;
+ led-failsafe = &led_power_red;
+ led-running = &led_power_green;
+ led-upgrade = &led_power_red;
+ label-mac-device = &eth0;
+ };
+
+ extosc: ref {
+ compatible = "fixed-clock";
+ #clock-cells = <0>;
+ clock-output-names = "ref";
+ clock-frequency = <40000000>;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power_green: led_power_green {
+ label = "ws-ap3610:green:power";
+ gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+ };
+
+ led_power_red: led_power_red {
+ label = "ws-ap3610:red:power";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ };
+
+ led_wlan5_blue {
+ label = "ws-ap3610:blue:wlan5";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ led_wlan5_green {
+ label = "ws-ap3610:green:wlan5";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ };
+
+ led_wlan2_blue {
+ label = "ws-ap3610:blue:wlan2";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ led_wlan2_green {
+ label = "ws-ap3610:green:wlan2";
+ gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pcie0 {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy0: ethernet-phy@0 {
+ /*
+ * When the compatible-is missing, PHY autodetection
+ * is performed, but the PHY-ID reads all 0xff.
+ *
+ * Linux does not create the device in this case,
+ * and the reset is never even de-asserted.
+ */
+ compatible = "ethernet-phy-id0143.bca2",
+ "ethernet-phy-ieee802.3-c22";
+ reg = <0>;
+
+ resets = <&rst 8>;
+ reset-names = "phy";
+ reset-assert-us = <10000>;
+ reset-deassert-us = <10000>;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-mode = "rgmii-id";
+ phy-handle = <&phy0>;
+};
+
+&spi {
+ status = "okay";
+
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x40000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-bak";
+ reg = <0x40000 0x40000>;
+ read-only;
+ };
+
+ partition@80000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x80000 0xe00000>;
+ };
+
+ partition@e80000 {
+ label = "cfg1";
+ reg = <0xe80000 0x40000>;
+ read-only;
+ };
+
+ partition@ec0000 {
+ label = "cfg2";
+ reg = <0xec0000 0x40000>;
+ read-only;
+ };
+
+ partition@f00000 {
+ label = "nvram1";
+ reg = <0xf00000 0x40000>;
+ read-only;
+ };
+
+ partition@f40000 {
+ label = "nvram2";
+ reg = <0xf40000 0x40000>;
+ read-only;
+ };
+
+ partition@f80000 {
+ label = "rsvd1";
+ reg = <0xf80000 0x40000>;
+ read-only;
+ };
+
+ partition@fc0000 {
+ label = "rsvd2";
+ reg = <0xfc0000 0x40000>;
+ read-only;
+ };
+ };
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index a3fcf35715..69c19358e2 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -30,6 +30,7 @@ ath79_setup_interfaces()
pisen,ts-d084|\
pisen,wmb001n|\
pisen,wmm003n|\
+ siemens,ws-ap3610|\
tplink,cpe210-v2|\
tplink,cpe210-v3|\
tplink,cpe510-v2|\
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index 8c8b7932bc..f814bd46ad 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -34,6 +34,9 @@ case "$board" in
[ "$PHYNBR" -eq 1 ] && \
k2t_get_mac "lan_mac" > /sys${DEVPATH}/macaddress
;;
+ siemens,ws-ap3610)
+ mtd_get_mac_ascii cfg1 RADIOADDR${PHYNBR} > /sys${DEVPATH}/macaddress
+ ;;
trendnet,tew-823dru)
# set the 2.4G interface mac address to LAN MAC
[ "$PHYNBR" -eq 1 ] && \
diff --git a/target/linux/ath79/generic/base-files/lib/preinit/10_fix_eth_mac.sh b/target/linux/ath79/generic/base-files/lib/preinit/10_fix_eth_mac.sh
new file mode 100644
index 0000000000..a0fb9fc717
--- /dev/null
+++ b/target/linux/ath79/generic/base-files/lib/preinit/10_fix_eth_mac.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+. /lib/functions.sh
+
+preinit_set_mac_address() {
+ case $(board_name) in
+ siemens,ws-ap3610)
+ ip link set dev eth0 address $(mtd_get_mac_ascii cfg1 ethaddr)
+ ;;
+ esac
+}
+
+boot_hook_add preinit_main preinit_set_mac_address
diff --git a/target/linux/ath79/generic/config-default b/target/linux/ath79/generic/config-default
index 2d8f7f20c2..6cd1518e3a 100644
--- a/target/linux/ath79/generic/config-default
+++ b/target/linux/ath79/generic/config-default
@@ -1,4 +1,5 @@
CONFIG_AT803X_PHY=y
+CONFIG_BROADCOM_PHY=y
CONFIG_GPIO_WATCHDOG=y
CONFIG_GPIO_WATCHDOG_ARCH_INITCALL=y
CONFIG_INTEL_XWAY_PHY=y
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 05d2ba6a75..d4693cea68 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1041,6 +1041,20 @@ define Device/rosinson_wr818
endef
TARGET_DEVICES += rosinson_wr818
+define Device/siemens_ws-ap3610
+ SOC := ar7161
+ DEVICE_VENDOR := Siemens
+ DEVICE_MODEL := WS-AP3610
+ IMAGE_SIZE := 14336k
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x82000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 8128 | uImage none
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
+endef
+TARGET_DEVICES += siemens_ws-ap3610
+
define Device/sitecom_wlr-7100
SOC := ar1022
DEVICE_VENDOR := Sitecom