aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:08 +0000
commitd1238718c23a818b1be2fca068974d8fb916a599 (patch)
tree2a908ceea1c0352f16721b1c7a82d84655b865ed /target
parent8cf868e1a62db5bd9f4cb92a71acc1c049a0db1b (diff)
downloadupstream-d1238718c23a818b1be2fca068974d8fb916a599.tar.gz
upstream-d1238718c23a818b1be2fca068974d8fb916a599.tar.bz2
upstream-d1238718c23a818b1be2fca068974d8fb916a599.zip
ar71xx: move the watchdog driver to the kernel
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37289
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/config-3.102
-rw-r--r--target/linux/ar71xx/modules.mk17
3 files changed, 2 insertions, 19 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 69c562d0a2..28faddc04c 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -18,7 +18,7 @@ LINUX_VERSION:=3.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
- kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+ kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
kmod-ath9k wpad-mini uboot-envtools
diff --git a/target/linux/ar71xx/config-3.10 b/target/linux/ar71xx/config-3.10
index b6d065b475..5f4fe41222 100644
--- a/target/linux/ar71xx/config-3.10
+++ b/target/linux/ar71xx/config-3.10
@@ -101,7 +101,7 @@ CONFIG_ATH79_MACH_ZCN_1523H=y
CONFIG_ATH79_NVRAM=y
CONFIG_ATH79_PCI_ATH9K_FIXUP=y
# CONFIG_ATH79_ROUTERBOOT is not set
-# CONFIG_ATH79_WDT is not set
+CONFIG_ATH79_WDT=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CEVT_R4K=y
CONFIG_CLONE_BACKWARDS=y
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index 601f473869..83747d6ce2 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -67,20 +67,3 @@ define KernelPackage/spi-vsc7385/description
endef
$(eval $(call KernelPackage,spi-vsc7385))
-
-
-define KernelPackage/wdt-ath79
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Atheros AR7XXX/AR9XXX watchdog timer
- DEPENDS:=@TARGET_ar71xx
- KCONFIG:=CONFIG_ATH79_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/ath79_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,ath79_wdt,1)
-endef
-
-define KernelPackage/wdt-ath79/description
- Kernel module for AR7XXX/AR9XXX watchdog timer.
-endef
-
-$(eval $(call KernelPackage,wdt-ath79))
-