aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-22 07:35:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-22 07:35:05 +0000
commitcfd684128b77f48e33030a8bd40a6073149f24ba (patch)
tree8331c1be1c4dd4b6ff3ce3b3f5d481ac702ded58 /target
parentf392b39fc52e3cd61792540d0bf1c7459db19b67 (diff)
downloadupstream-cfd684128b77f48e33030a8bd40a6073149f24ba.tar.gz
upstream-cfd684128b77f48e33030a8bd40a6073149f24ba.tar.bz2
upstream-cfd684128b77f48e33030a8bd40a6073149f24ba.zip
fix Ubiquiti RouterStation images
SVN-Revision: 14144
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index fea4691aee..6ed652e6bc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -68,7 +68,8 @@ endef
define Image/Build/UBNT
cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
- $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).lzma
+ dd if=$(KDIR)/vmlinux-$(2).lzma of=$(KDIR)/vmlinux-$(2).bin.lzma bs=64k conv=sync
-$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(4) -v $(5).ar7100.OpenWrt \
-k $(KDIR)/vmlinux-$(2).bin.lzma \