aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-08 18:40:37 +0100
committerFelix Fietkau <nbd@nbd.name>2018-02-05 10:15:53 +0100
commitcde71a543c629f63e6f01850fd8b6f3f94cdd25d (patch)
tree61a463012d3958e88e256b27f43e939dfd0b03a0 /target
parentecc347dd6e175b23590dc4ddb91344397d3eeb4d (diff)
downloadupstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.tar.gz
upstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.tar.bz2
upstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.zip
build: replace uses of OpenWrt with $(VERSION_DIST)
This makes the distribution name more configurable. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile2
-rw-r--r--target/linux/ar71xx/image/generic.mk6
-rw-r--r--target/linux/ar71xx/image/legacy.mk14
-rw-r--r--target/linux/ath25/image/Makefile2
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk6
-rw-r--r--target/linux/cns3xxx/image/Makefile4
-rw-r--r--target/linux/lantiq/image/Makefile2
-rw-r--r--target/linux/mcs814x/image/Makefile2
-rw-r--r--target/linux/ramips/image/Makefile2
9 files changed, 20 insertions, 20 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index c012906eaf..82a857a4d0 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -118,7 +118,7 @@ define Build/create-uImage-dtb
# flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
-$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \
-O linux -T kernel -C none \
- -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' \
+ -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $(IMAGE_KERNEL).dtb $@.new
@mv $@.new $@
endef
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index b2e701c844..95265d1c0a 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -28,7 +28,7 @@ define Build/mkwrggimg
$(STAGING_DIR_HOST)/bin/mkwrggimg -b \
-i $@ -o $@.imghdr -d /dev/mtdblock/1 \
-m $(BOARDNAME) -s $(DAP_SIGNATURE) \
- -v OpenWrt -B $(REVISION)
+ -v $(VERSION_DIST) -B $(REVISION)
mv $@.imghdr $@
endef
@@ -46,7 +46,7 @@ define Build/netgear-squashfs
-A mips -O linux -T filesystem -C none \
-M $(NETGEAR_KERNEL_MAGIC) \
-a 0xbf070000 -e 0xbf070000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $@.squashfs $@
rm -rf $@.squashfs $@.fs
endef
@@ -93,7 +93,7 @@ define Build/uImageHiWiFi
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+ -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $@ $@.new
@mv $@.new $@
endef
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index bd8ca2cefe..cbc859dd08 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -87,7 +87,7 @@ ifneq ($(SUBTARGET),mikrotik)
# $(4): output file.
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
- -e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e 0x80060000 -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $(3) $(4)
endef
@@ -484,11 +484,11 @@ define Image/Build/Belkin
$(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
$(call Sysupgrade/RKuImage,$(1),$(2),$(kernsize),$(rootsize))
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+ edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
-n "uImage" \
-i $(KDIR_TMP)/vmlinux-$(2).uImage \
-o $(KDIR_TMP)/$(2)-uImage; \
- edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+ edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
-n "rootfs" \
-i $(KDIR)/root.$(1) \
-o $(KDIR_TMP)/$(2)-rootfs; \
@@ -661,7 +661,7 @@ define Image/Build/Netgear/buildkernel
) > $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2
mkimage -A mips -O linux -T filesystem -C none -M $(5) \
-a 0xbf070000 -e 0xbf070000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2 \
$(KDIR_TMP)/vmlinux-$(2).uImage.squashfs
endef
@@ -673,7 +673,7 @@ define Image/Build/Netgear
for r in $(7) ; do \
[ -n "$$r" ] && dashr="-$$r" || dashr= ; \
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+ -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
-i $(call sysupname,$(1),$(2)) \
-o $(call imgname,$(1),$(2))-factory$$dashr.img; \
done; \
@@ -714,7 +714,7 @@ define Image/Build/NetgearNAND/buildkernel
dd if=/dev/zero of=$(KDIR_TMP)/fakeroot-$(2) bs=131072 count=1
mkimage -A mips -O linux -T filesystem -C none \
-a 0xbf070000 -e 0xbf070000 \
- -n 'MIPS OpenWrt fakeroot' \
+ -n 'MIPS $(VERSION_DIST) fakeroot' \
-d $(KDIR_TMP)/fakeroot-$(2) \
-M $(5) \
$(KDIR_TMP)/fakeroot-$(2).uImage
@@ -745,7 +745,7 @@ define Image/Build/NetgearNAND
dd if=$(KDIR_TMP)/$(2)-root.ubi \
) > $(imageraw)
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+ -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
-i $(imageraw) \
-o $(call imgname,ubi,$(2))-factory.img
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index 5144ed8a0a..5a20bdb644 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
define Build/mkfwimage
$(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(1).OpenWrt.$(REVISION) \
+ -B $(1).$(VERSION_DIST).$(REVISION) \
-k $(IMAGE_KERNEL) \
-r $(IMAGE_ROOTFS) \
-o $@.new && \
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 918dfc7981..b9ecd54064 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -990,7 +990,7 @@ define Device/NEUFBOX4-SER
DEVICE_DTS := nb4-ser-r0
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+ CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -1002,7 +1002,7 @@ define Device/NEUFBOX4-FXC
DEVICE_DTS := nb4-fxc-r1
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+ CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -1014,7 +1014,7 @@ define Device/NEUFBOX6
DEVICE_DTS := nb6-ser-r0
CFE_BOARD_ID := NB6-SER-r0
CFE_CHIP_ID := 6362
- CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+ CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 99bb7f1a22..d095ce11f4 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
+ mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n '$(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
endef
LEGACY_NOR_KERNEL_SIZE = 2048k
@@ -27,7 +27,7 @@ define BuildFirmware/Legacy
endef
define Image/BuildKernel/Initramfs
- mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-uImage
+ mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n '$(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-uImage
endef
define Image/Build
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index dcd0c710d1..2e8eccf5ac 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -39,7 +39,7 @@ endef
define Build/fullimage
mkimage -A mips -O linux -C lzma -T filesystem -a 0x00 \
- -e 0x00 -n 'OpenWrt RootFS' \
+ -e 0x00 -n '$(VERSION_DIST) RootFS' \
-d $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).new
cat $(IMAGE_KERNEL) $(IMAGE_ROOTFS).new > $@.tmp
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 3afd660c14..ff905b3085 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -20,7 +20,7 @@ UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
define Image/Build/MkuImage
mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
- -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
+ -n 'ARM $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(1) $(2);
endef
define Image/Build/DTB
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index ea7ce0bc90..abcff03629 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -118,7 +118,7 @@ endef
# $(2), filename of image data
# $(3), output filename
define MkImage
- $(eval imagename=$(if $(4),$(4),MIPS OpenWrt Linux-$(LINUX_VERSION)))
+ $(eval imagename=$(if $(4),$(4),MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)))
-mkimage -A mips -O linux -T kernel -C $(1) -a $(loadaddr-y) -e $(loadaddr-y) \
-n "$(imagename)" \
-d $(2) $(3)