aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTobias Wolf <github-NTEO@vplace.de>2016-12-21 13:56:16 +0100
committerJo-Philipp Wich <jo@mein.io>2017-02-02 00:13:49 +0100
commitbf2f09c00593a131287d1cb152485f9a08319058 (patch)
treebd9d51f2ed1d7f830930f4d7e77c03b8488b1c5e /target
parent4f866929533e76efa6068dda07eebe6113d67ef6 (diff)
downloadupstream-bf2f09c00593a131287d1cb152485f9a08319058.tar.gz
upstream-bf2f09c00593a131287d1cb152485f9a08319058.tar.bz2
upstream-bf2f09c00593a131287d1cb152485f9a08319058.zip
ramips: Introduce CONFIG_MIPS_APPENDED_RAW_DTB to F5D8235 V1 (rt288x)
This activates the CONFIG_MIPS_APPENDED_RAW_DTB kernel configuration and configures the F5D8235 V1 target to use append-dtb for kernel creation instead of OWRTDTB. Signed-off-by: Tobias Wolf <github-NTEO@vplace.de> [Jo-Philipp Wich: rewrap commit message] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile1
-rw-r--r--target/linux/ramips/image/rt288x.mk4
-rw-r--r--target/linux/ramips/rt288x/config-4.44
3 files changed, 6 insertions, 3 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index f34eba79cd..7196a4664f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -36,6 +36,7 @@ define Device/Default
PROFILES = Default $$(DTS)
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
KERNEL := $(KERNEL_DTB) | uImage lzma
+ DEVICE_DTS_DIR := ../dts
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
SUPPORTED_DEVICES = $(1)
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 53fc99abda..fbe50a2824 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -28,11 +28,13 @@ endef
TARGET_DEVICES += ar725w
define Device/f5d8235-v1
- DTS := F5D8235_V1
IMAGE_SIZE := 7744k
DEVICE_TITLE := Belkin F5D8235 V1
DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+ DEVICE_DTS := F5D8235_V1
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
endef
TARGET_DEVICES += f5d8235-v1
diff --git a/target/linux/ramips/rt288x/config-4.4 b/target/linux/ramips/rt288x/config-4.4
index 5f29322874..bff04da39a 100644
--- a/target/linux/ramips/rt288x/config-4.4
+++ b/target/linux/ramips/rt288x/config-4.4
@@ -119,8 +119,8 @@ CONFIG_MIPS_CMDLINE_FROM_DTB=y
CONFIG_MIPS_L1_CACHE_SHIFT=4
CONFIG_MIPS_L1_CACHE_SHIFT_4=y
# CONFIG_MIPS_MACHINE is not set
-CONFIG_MIPS_NO_APPENDED_DTB=y
-# CONFIG_MIPS_RAW_APPENDED_DTB is not set
+# CONFIG_MIPS_NO_APPENDED_DTB is not set
+CONFIG_MIPS_RAW_APPENDED_DTB=y
CONFIG_MIPS_SPRAM=y
CONFIG_MODULES_USE_ELF_REL=y
# CONFIG_MTD_CFI_INTELEXT is not set